diff mbox series

[bug#62100] gnu: Remove python-pre-commit.

Message ID 20230310171727.14525-1-antero@mailbox.org
State New
Headers show
Series [bug#62100] gnu: Remove python-pre-commit. | expand

Commit Message

Antero Mejr March 10, 2023, 5:17 p.m. UTC
* gnu/packages/python-xyz.scm (python-pre-commit): Delete variable.
* gnu/packages/version-control.scm (pre-commit): Add comment referencing
python-pre-commit.
---
Please apply this patch last, after the rest of the series.
Will cause ~70-80 rebuilds from what I can see.

pre-commit and python-pre-commit are duplicates, but pre-commit is better
packaged and newer. pre-commit should never be a native-input of python
packages: it's a package manager for commit linting, which is completely
irrelevant to builds.

Resolves 53502:
https://issues.guix.gnu.org/53502

 gnu/packages/python-xyz.scm      | 30 ------------------------------
 gnu/packages/version-control.scm |  2 +-
 2 files changed, 1 insertion(+), 31 deletions(-)

Comments

Lars-Dominik Braun March 11, 2023, 7:56 a.m. UTC | #1
Hi,

> * gnu/packages/python-xyz.scm (python-pre-commit): Delete variable.

usually we don’t delete variables just like that, because it breaks
existing manifests and channels depending on it. Please use
deprecated-package.

Perhaps we should also update the linter to flag this package or the
PyPi importer to not add it in the first place.

Cheers,
Lars
Antero Mejr March 11, 2023, 1:41 p.m. UTC | #2
Lars-Dominik Braun <lars@6xq.net> writes:

> usually we don’t delete variables just like that, because it breaks
> existing manifests and channels depending on it. Please use
> deprecated-package.

Fixed in v3.

> Perhaps we should also update the linter to flag this package or the
> PyPi importer to not add it in the first place.

Added python-pre-commit to the
check-inputs-should-not-be-an-input-at-all linter in v3.
Lars-Dominik Braun March 12, 2023, 11:14 a.m. UTC | #3
Hi,

> Fixed in v3.

thanks. I pushed v3 as:

a70b9fb319 (lint: Check that python-pre-commit is not an input., 2023-03-11)
831baaf81e (gnu: python-pre-commit: Replace with pre-commit., 2023-03-11)
5c976c6b45 (gnu: python-sphinxcontrib-apidoc: Remove python-pre-commit., 2023-03-11)
dcc3bebfaf (gnu: mdpo: Remove python-pre-commit., 2023-03-11)
57a94b9eff (gnu: python-pytest-regressions: Remove python-pre-commit., 2023-03-11)
72b1fe77b2 (gnu: scvelo: Remove python-pre-commit., 2023-03-11)
ed59796de5 (gnu: python-doubletdetection: Remove python-pre-commit., 2023-03-11)
fb624c919f (gnu: python-minikanren: Remove python-pre-commit., 2023-03-11)
f19ab875ff (gnu: python-apispec-webframeworks: Remove python-pre-commit., 2023-03-11)
6181cce732 (gnu: python-apispec: Remove python-pre-commit., 2023-03-11)
2cfb7dbd2f (gnu: python-marshmallow-jsonapi: Remove python-pre-commit., 2023-03-11)
a83f3a13e6 (gnu: python-marshmallow: Remove python-pre-commit., 2023-03-11)
d456ced2d4 (gnu: python-pyjwt: Remove python-pre-commit., 2023-03-11)
622b92d935 (gnu: python-bidict: Remove python-pre-commit., 2023-03-11)
64d69c3f79 (gnu: python-jupytext: Replace python-pre-commit with pre-commit., 2023-03-11)
94c898cd9b (gnu: pre-commit: Update to 3.1.1., 2023-03-11)

Cheers,
Lars
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8243bb9fd3..b2fb60f322 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24284,36 +24284,6 @@  (define-public python-retrying
 @end itemize")
     (license license:asl2.0)))
 
-(define-public python-pre-commit
-  (package
-    (name "python-pre-commit")
-    (version "2.10.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pre_commit" version))
-       (sha256
-        (base32 "1ycf6wpxrhxhdzz0vpryhbdxlwik5khgcvp3hxwvfr447a6k84zl"))))
-    (build-system python-build-system)
-    (arguments
-     ;; Tests fail with "AttributeError: module 'pre_commit.resources' has no
-     ;; attribute 'empty_template_setup'".
-     `(#:tests? #false))
-    (propagated-inputs
-     (list python-cfgv
-           python-identify
-           python-importlib-metadata
-           python-nodeenv
-           python-pyyaml
-           python-toml
-           python-virtualenv))
-    (home-page "https://github.com/pre-commit/pre-commit")
-    (synopsis "Framework for managing multi-language pre-commit hooks")
-    (description
-     "This package provides a framework for managing and maintaining
-multi-language pre-commit hooks.")
-    (license license:expat)))
-
 (define-public python-precis-i18n
   (package
     (name "python-precis-i18n")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8b0997768d..96378a73d3 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1667,7 +1667,7 @@  (define-public gitile
 
 (define-public pre-commit
   (package
-    (name "pre-commit")
+    (name "pre-commit") ;formerly known as python-pre-commit
     (version "2.20.0")
     (source
      (origin