diff mbox series

[bug#62077] gnu: Add python-slugid.

Message ID 82177a4f-a75d-a15d-117b-6f06a9adcb33@disroot.org
State New
Headers show
Series [bug#62077] gnu: Add python-slugid. | expand

Commit Message

Adam Faiz March 9, 2023, 4:46 p.m. UTC
From f788ce8ebc205a6e05bcc270865d793d94bf51e9 Mon Sep 17 00:00:00 2001
Message-Id: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:39:13 +0800
Subject: [PATCH] gnu: Add python-slugid.

* gnu/packages/python-xyz.scm (python-slugid): New variable.
---
  gnu/packages/python-xyz.scm | 17 +++++++++++++++++
  1 file changed, 17 insertions(+)


base-commit: 5befcff66edb4d72ab8e713c81836fb8519ce3e6

Comments

jgart March 9, 2023, 6:03 p.m. UTC | #1
Hi, 

I'll test this out from my end today and report back. Thanks for the patch!

all best,

jgart
jgart May 19, 2023, 6:03 a.m. UTC | #2
Hi Adam,

I merged v2. Thanks for your contribution to GNU Guix.

all best,

jgart
jgart May 19, 2023, 6:04 a.m. UTC | #3
done
jgart May 19, 2023, 6:15 a.m. UTC | #4
close 62077
jgart May 19, 2023, 6:27 a.m. UTC | #5
"close 62077"
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..4bacd86432 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1096,6 +1096,23 @@  (define-public python-slixmpp
      (home-page "https://lab.louiz.org/poezio/slixmpp")
      (license license:expat)))
  
+(define-public python-slugid
+  (package
+    (name "python-slugid")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "slugid" version))
+              (sha256
+               (base32
+                "15x2kgzi38b023brfyng0y907am2qi1jgifnsjyph4b9fa5xjl59"))))
+    (build-system python-build-system)
+    (home-page "http://taskcluster.github.io/slugid.py/")
+    (synopsis "Module for Base64 encoded UUID v4 slugs")
+    (description "Slugid.py is a module for generating v4 UUIDs and
+encoding them into 22 character URL-safe base64 slug representation.")
+    (license license:mpl2.0)))
+
  (define-public python-tenacity
    (package
      (name "python-tenacity")