diff mbox series

[bug#61789,26/27] services: dict: Deprecate 'dicod-service' procedure.

Message ID 78a98543d37badae1619ffd46b47f1e866606fd1.1677350250.git.mirai@makinata.eu
State New
Headers show
Series Deprecate old-style services. | expand

Commit Message

Bruno Victal Feb. 25, 2023, 6:58 p.m. UTC
* doc/guix.texi (Miscellaneous Services): Remove 'dicod-service' mention.
* gnu/services/dict.scm (dicod-service): Deprecate procedure.
---
 doc/guix.texi         | 17 ++---------------
 gnu/services/dict.scm |  6 ++++--
 2 files changed, 6 insertions(+), 17 deletions(-)

Comments

Ludovic Courtès March 3, 2023, 4:52 p.m. UTC | #1
Bruno Victal <mirai@makinata.eu> skribis:

> * doc/guix.texi (Miscellaneous Services): Remove 'dicod-service' mention.
> * gnu/services/dict.scm (dicod-service): Deprecate procedure.
> ---
>  doc/guix.texi         | 17 ++---------------
>  gnu/services/dict.scm |  6 ++++--
>  2 files changed, 6 insertions(+), 17 deletions(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index 7aa9f3a5e8..a40d88455b 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -37814,19 +37814,6 @@ Miscellaneous Services
>  implementation of DICT server (@pxref{Dicod,,, dico, GNU Dico Manual}).
>  @end defvar
>  
> -@deffn {Scheme Procedure} dicod-service [#:config (dicod-configuration)]
> -Return a service that runs the @command{dicod} daemon, an implementation
> -of DICT server (@pxref{Dicod,,, dico, GNU Dico Manual}).
> -
> -The optional @var{config} argument specifies the configuration for
> -@command{dicod}, which should be a @code{<dicod-configuration>} object, by
> -default it serves the GNU Collaborative International Dictionary of English.
> -
> -You can add @command{open localhost} to your @file{~/.dico} file to make
> -@code{localhost} the default server for @command{dico} client
> -(@pxref{Initialization File,,, dico, GNU Dico Manual}).
> -@end deffn

Could you move the documentation above under ‘dicod-service-type’?

Ludo’.
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 7aa9f3a5e8..a40d88455b 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -37814,19 +37814,6 @@  Miscellaneous Services
 implementation of DICT server (@pxref{Dicod,,, dico, GNU Dico Manual}).
 @end defvar
 
-@deffn {Scheme Procedure} dicod-service [#:config (dicod-configuration)]
-Return a service that runs the @command{dicod} daemon, an implementation
-of DICT server (@pxref{Dicod,,, dico, GNU Dico Manual}).
-
-The optional @var{config} argument specifies the configuration for
-@command{dicod}, which should be a @code{<dicod-configuration>} object, by
-default it serves the GNU Collaborative International Dictionary of English.
-
-You can add @command{open localhost} to your @file{~/.dico} file to make
-@code{localhost} the default server for @command{dico} client
-(@pxref{Initialization File,,, dico, GNU Dico Manual}).
-@end deffn
-
 @deftp {Data Type} dicod-configuration
 Data type representing the configuration of dicod.
 
@@ -37890,10 +37877,10 @@  Miscellaneous Services
 Dictionary of English using the @code{gcide} package.
 @end defvar
 
-The following is an example @code{dicod-service} configuration.
+The following is an example @code{dicod-service-type} configuration.
 
 @lisp
-(dicod-service #:config
+(service dicod-service-type
   (dicod-configuration
    (handlers (list (dicod-handler
                     (name "wordnet")
diff --git a/gnu/services/dict.scm b/gnu/services/dict.scm
index 35253a0077..5a61085316 100644
--- a/gnu/services/dict.scm
+++ b/gnu/services/dict.scm
@@ -19,6 +19,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu services dict)
+  #:use-module (guix deprecation)
   #:use-module (guix gexp)
   #:use-module (guix records)
   #:use-module (guix modules)
@@ -34,7 +35,7 @@  (define-module (gnu services dict)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26)
   #:use-module (ice-9 match)
-  #:export (dicod-service
+  #:export (dicod-service  ; deprecated
             dicod-service-type
             dicod-configuration
             dicod-handler
@@ -202,7 +203,8 @@  (define dicod-service-type
 implements the standard DICT protocol supported by clients such as
 @command{dico} and GNOME Dictionary.")))
 
-(define* (dicod-service #:key (config (dicod-configuration)))
+(define-deprecated (dicod-service #:key (config (dicod-configuration)))
+  dicod-service-type
   "Return a service that runs the @command{dicod} daemon, an implementation
 of DICT server (@pxref{Dicod,,, dico, GNU Dico Manual}).