diff mbox series

[bug#61859] gnu: python-acme, certbot: Update to 2.3.0.

Message ID 20230228020627.10374-1-jackhill@jackhill.us
State New
Headers show
Series [bug#61859] gnu: python-acme, certbot: Update to 2.3.0. | expand

Commit Message

Jack Hill Feb. 28, 2023, 2:06 a.m. UTC
* gnu/packages/tls.scm (python-acme): Update to 2.3.0.
(certbot)[source]: Update hash.
[propagated-inputs]: Remove python-zope-interface and
python-zope-component.
---

I built python-acme, certbot, and the dependent, synapse, on linux x86_64.
I also tested the certbot-service, and was able to renew a certificate
against my local (non-LetsEcrypt) ACME server. Preveious to this update
responses from that server were causing certbot to print a stacktrace.

 gnu/packages/tls.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Comments

Leo Famulari March 2, 2023, 6:51 p.m. UTC | #1
On Mon, Feb 27, 2023 at 09:06:27PM -0500, Jack Hill wrote:
> * gnu/packages/tls.scm (python-acme): Update to 2.3.0.
> (certbot)[source]: Update hash.
> [propagated-inputs]: Remove python-zope-interface and
> python-zope-component.
> ---
> 
> I built python-acme, certbot, and the dependent, synapse, on linux x86_64.
> I also tested the certbot-service, and was able to renew a certificate
> against my local (non-LetsEcrypt) ACME server. Preveious to this update
> responses from that server were causing certbot to print a stacktrace.

Thanks! Pushed as ffb756e8c008e64d05b510e365d5e6b907c65747
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 59e0e28feb..81d90c86ae 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -764,13 +764,13 @@  (define-public python-acme
   (package
     (name "python-acme")
     ;; Remember to update the hash of certbot when updating python-acme.
-    (version "1.28.0")
+    (version "2.3.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "acme" version))
               (sha256
                (base32
-                "12fmw4g63pzbrmmrkk6hgg0k5px6jyx3scv9fmn60h21387jv0hz"))))
+                "1z6293g4pyxvx5w7v07j8wnaxyr7srsqfqvgly888b8k52fq9ipa"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -822,7 +822,7 @@  (define-public certbot
               (uri (pypi-uri "certbot" version))
               (sha256
                (base32
-                "0p4cpakx1kc8lczlgxqryr2asnyrvw6p5wmkamkjqdsf3z7xhm2b"))))
+                "12nd9nmdj3bf1xlvhj1ln473xbyv4qzxf6qhz0djbca7jl59zlwk"))))
     (build-system python-build-system)
     (arguments
      `(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -850,13 +850,11 @@  (define-public certbot
     (propagated-inputs
      (list python-acme
            python-cryptography
-           python-zope-interface
            python-pyrfc3339
            python-pyopenssl
            python-configobj
            python-configargparse
            python-distro
-           python-zope-component
            python-parsedatetime
            python-psutil
            python-requests