diff mbox series

[bug#61524] gnu: aspell: fix cross-compile.

Message ID tencent_75752A4AD6DD9F80CE6F394949592DF36606@qq.com
State New
Headers show
Series [bug#61524] gnu: aspell: fix cross-compile. | expand

Commit Message

Z572 Feb. 15, 2023, 2:41 a.m. UTC
* gnu/packages/aspell.scm (aspell): fix cross-compile.
[inputs]: move perl to ...
[native-inputs]: here.
---
 gnu/packages/aspell.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: c0e9ddfa290056f137ee21a53be6be4fbb8586ea

Comments

宋文武 March 1, 2023, 6:56 a.m. UTC | #1
Z572 <873216071@qq.com> writes:

> * gnu/packages/aspell.scm (aspell): fix cross-compile.
> [inputs]: move perl to ...
> [native-inputs]: here.

Pushed, thank you!

(Note: this doesn't change the output hash, so it's safe to push).
diff mbox series

Patch

diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 8978b4e087..fce0f37d25 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
 ;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -74,7 +75,7 @@  (define-public aspell
                   (string-append "\"filter-path" middle
                                  "\"" libdir "\"")))
                #t))))))
-    (inputs (list perl))
+    (native-inputs (list perl))
 
     (native-search-paths
      ;; This is a Guix-specific environment variable that takes a single