diff mbox series

[bug#61339] gnu: Add smartdns.

Message ID 87zg9qdnl1.wl-hako@ultrarare.space
State New
Headers show
Series [bug#61339] gnu: Add smartdns. | expand

Commit Message

Hilton Chain Feb. 7, 2023, 5:57 a.m. UTC
* gnu/packages/dns.scm (smartdns): New variable.
---
 gnu/packages/dns.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 1f684d00d25f0f205c4cc4b762d8f56911062581

Comments

Nicolas Goaziou Feb. 11, 2023, 9:15 p.m. UTC | #1
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/dns.scm (smartdns): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 6eac4fa542..ef65dfa713 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Simon South <simon@simonsouth.net>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1389,3 +1390,38 @@  (define-public openresolv
 configure the real @file{/etc/resolv.conf} and optionally any local
 nameservers other than libc.")
     (license license:bsd-2)))
+
+(define-public smartdns
+  (package
+    (name "smartdns")
+    (version "40")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pymumu/smartdns")
+                    (commit (string-append "Release" version))))
+              (file-name (git-file-name name version))
+              (modules '((guix build utils)))
+              (snippet '(substitute* "Makefile"
+                          ((".*SYSTEMDSYSTEMUNITDIR.*") "")))
+              (sha256
+               (base32
+                "0ibbj96s40xgk6q7dsgpx65rjkknl1pn7nca5fcbbhcm2m80nzjj"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f                  ;no tests
+           #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "DESTDIR=" #$output)
+                   "PREFIX=''")
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))
+    (inputs (list openssl))
+    (home-page "https://github.com/pymumu/smartdns")
+    (synopsis "Local DNS server")
+    (description
+     "This package provides @code{SmartDNS}, a DNS server which accepts DNS
+query requests from local clients, obtains DNS query results from multiple
+upstream DNS servers, and returns the fastest access results to clients.")
+    (license license:gpl3+)))