diff mbox series

[bug#61139] gnu: emacs-next: Enable tree-sitter support.

Message ID 87a6217tw5.fsf@riseup.net
State New
Headers show
Series [bug#61139] gnu: emacs-next: Enable tree-sitter support. | expand

Commit Message

Declan Tsien Jan. 29, 2023, 6:10 a.m. UTC

Comments

Luis Henrique Gomes Higino Jan. 29, 2023, 3:26 p.m. UTC | #1
Hi Declan,

>  (define-public emacs-next
> -  (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
> -        (revision "4"))
> +  (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
> +        (revision "1"))

Revision numbers start at 0 if I'm not mistaken.

>        (inputs
>         (modify-inputs (package-inputs emacs)
>           (prepend sqlite)))
> +      (propagated-inputs
> +       (modify-inputs (package-propagated-inputs emacs)
> +         (prepend tree-sitter)))
>        (native-inputs
>         (modify-inputs (package-native-inputs emacs)
>           (prepend autoconf))))))

Is there any reason for tree-sitter to be added as a propagated 
input? It does not provide any binaries and I tested changing it 
to a normal input and c-ts-mode worked fine.

Regards,
Andrew Tropin Feb. 4, 2023, 4:51 a.m. UTC | #2
On 2023-01-30 10:02, Declan Tsien wrote:

> Hey Luis,
>
> Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:
>
>> Hi Declan,
>>
>> tried your newest patch and it LGTM. The only problem I see now is 
>> that your copyright's year is wrong haha.
>>
>> Regards,
>> -- 
>> Luis H. Higino

Hi Declan,

Thank you very much for the patch, applied it, updated emacs commit to
ac7ec87a7a0db887e4ae7fe9005aea517958b778 and pushed as
6f0c9053244d6b4cfc4130c963a15dbf83cbcdac.
diff mbox series

Patch

From d51a7e7812beec431e79164efe9d7cb87341674e Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sun, 29 Jan 2023 13:34:03 +0800
Subject: [PATCH] gnu: emacs-next: Enable tree-sitter support.

* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-1.2bd0b94.
* gnu/packages/emacs.scm (emacs-next)[propagated-inputs]: Add tree-sitter.
---
 gnu/packages/emacs.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 299ab5e992..ed62f6ec8b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Declan Tsien <declantsien@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -75,6 +76,7 @@  (define-module (gnu packages emacs)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages text-editors) ; for tree-sitter
   #:use-module (gnu packages web)       ; for jansson
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xml)
@@ -381,12 +383,12 @@  (define* (emacs-byte-compile-directory dir)
     (license license:gpl3+)))
 
 (define-public emacs-next
-  (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
-        (revision "4"))
+  (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
+        (revision "1"))
     (package
       (inherit emacs)
       (name "emacs-next")
-      (version (git-version "29.0.50" revision commit))
+      (version (git-version "29.0.60" revision commit))
       (source
        (origin
          (inherit (package-source emacs))
@@ -401,10 +403,13 @@  (define-public emacs-next
                                   "emacs-native-comp-driver-options.patch"))
          (sha256
           (base32
-           "0b48qg9w7fzvhva78gzi3cs2m6asj11fk0kgys49fqhwskigzg1f"))))
+           "0pf2qlbfddpzp38x6rpz0qpadwa3vgrp3dik3a4wr3cdcby98cc3"))))
       (inputs
        (modify-inputs (package-inputs emacs)
          (prepend sqlite)))
+      (propagated-inputs
+       (modify-inputs (package-propagated-inputs emacs)
+         (prepend tree-sitter)))
       (native-inputs
        (modify-inputs (package-native-inputs emacs)
          (prepend autoconf))))))

base-commit: bea22409682f6d1947de7d92f264aad822c2e68c
-- 
2.39.1