diff mbox series

[bug#61218] gnu: Add emacs-jabber.

Message ID 20230201203121.14910-1-antero@mailbox.org
State New
Headers show
Series [bug#61218] gnu: Add emacs-jabber. | expand

Commit Message

Antero Mejr Feb. 1, 2023, 8:31 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-jabber): New variable.
---
Please apply in reverse order, thanks.

 gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Nicolas Goaziou Feb. 3, 2023, 10:47 p.m. UTC | #1
Hello,

Antero Mejr via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-jabber): New variable.
> ---
> Please apply in reverse order, thanks.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b98798a7d2..ae3466bb1a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35653,6 +35653,42 @@  (define-public emacs-srv
 in turn.")
     (license license:gpl2+)))
 
+(define-public emacs-jabber
+  ;; No releases available.
+  (let ((commit "af0315e174fa6446d5c4dd3e6465d48912950e58")
+        (revision "0"))
+    (package
+      (name "emacs-jabber")
+      (version (git-version "0.8.92" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://codeberg.org/emacs-jabber/emacs-jabber")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "08q0hbm4pvp8sf261w1ihqa93sg8blfybfkhq7wrnvgs6kasgwvq"))))
+      (build-system emacs-build-system)
+      (arguments
+       (list #:emacs emacs ;requires gnutls
+             #:phases #~(modify-phases %standard-phases
+                          (add-after 'build 'make-info
+                            (lambda _
+                              (invoke "makeinfo" "jabber.texi")
+                              (install-file "jabber.info"
+                                            (string-append #$output
+                                                           "/share/info")))))))
+      (native-inputs (list texinfo))
+      (propagated-inputs (list emacs-fsm emacs-hexrgb emacs-srv gnutls))
+      (home-page "https://codeberg.org/emacs-jabber/emacs-jabber")
+      (synopsis "XMPP (Jabber) client for Emacs")
+      (description
+       "@code{jabber.el} is an XMPP client for Emacs.  XMPP (also known as
+\"Jabber\") is an instant messaging system; see @url{https://xmpp.org} for more
+information.")
+      (license license:gpl2+))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar