diff mbox series

[bug#61157] gnu: Add uwufetch.

Message ID PCtpn4Z54R3M2psFCibuS_3kC0Mtx_SuQBM13k9MDPeo0C_c6PBze-ro4I74HrK-IVBtvYTlaPcvGlX9sIT_F8Py_j9eN-WTGSsAEjk0i4U=@protonmail.com
State New
Headers show
Series [bug#61157] gnu: Add uwufetch. | expand

Commit Message

J. Sims Jan. 29, 2023, 9:59 p.m. UTC
Hello,

This is a fun little fetch utility and I thought it might enjoy inclusion in Guix.

Thanks,
Juli

Comments

Nicolas Goaziou Jan. 31, 2023, 2:19 p.m. UTC | #1
Hello,

"J. Sims via Guix-patches" via <guix-patches@gnu.org> writes:

> This is a fun little fetch utility and I thought it might enjoy
> inclusion in Guix.

Thank you. Some comments follow.

> +    (build-system gnu-build-system)
> +    (arguments
> +     (list #:tests? #f ;no tests

Please add a newline character after "list".

> +           #:make-flags #~(list (string-append "DESTDIR="
> +                                               #$output)
> +                                (string-append "ETC_DIR="
> +                                               #$output "/etc")
> +                                (string-append "CC="
> +                                               #$(cc-for-target)))

Please also add a newline character after "flags". Every flag should fit
into a single line.

> +           #:phases (with-imported-modules '((guix build utils))

I don'tthink you need to import modules.

> +                                           #~(modify-phases %standard-phases
> +                                               (delete 'configure)
> +                                               (add-before 'build 'path-source-paths
> +                                                 (lambda _
> +                                                   (substitute* "uwufetch.c"
> +                                                     (("(/usr(/local)?)(.*;)"
> +                                                       all _ _ rest)
> +                                                      (string-append #$output
> +                                                                     rest)))))))))

You can move this below "#:phases" to drastically improve indentation.

> +    (native-inputs (list git))

Are you sure git is required as a native input? If it is, then this
should be `git-minimal' instead.


> +    (synopsis "Cutesie *fetch utility")

I think we should provide better than this synopsis. Maybe, according
to upstream's About,

  Meme system info tool based on Nyan/UwU trend 

> +    (description
> +     "UwUFetch is a system information tool in the lineage of @code{neofetch},
> +@code{pfetch}, @{hyfetch}, and the like. It prints ASCII art of your system's

I suggest to use Neofetch instead of @code{neofetch}, Pfetch instead of
@code{pfetch} and HyFetch instead of (mind the typo!) @code{hyfetch}.

> +logo as well as a summary of system information. UwUFetch's unique contribution
> +is the uwu-ification of various words used in the description. For example, Guix
> +become gUwUix.")

Sentences should be separated with two spaces.

> +    (license license:gpl3)))

License is actually GPL3+.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 17bff0290e443766b6f5cd9ff211c0026ded0bae Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 29 Jan 2023 15:44:48 -0600
Subject: [PATCH] gnu: Add uwufetch.

* gnu/packages/admin.scm (uwufetch): Add uwufetch.
---
 gnu/packages/admin.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5cea17d562..8babf4227e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3944,6 +3945,52 @@  (define-public hyfetch
 you are running, what theme or icon set you are using, etc.")
     (license license:expat)))
 
+(define-public uwufetch
+  (package
+    (name "uwufetch")
+    (version "2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/TheDarkBug/uwufetch")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0s4pzaqmlq6rn54kgmlpcrc0sy3q5zn6lxh4448k9iimshljsjfs"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f ;no tests
+           #:make-flags #~(list (string-append "DESTDIR="
+                                               #$output)
+                                (string-append "ETC_DIR="
+                                               #$output "/etc")
+                                (string-append "CC="
+                                               #$(cc-for-target)))
+           #:phases (with-imported-modules '((guix build utils))
+                                           #~(modify-phases %standard-phases
+                                               (delete 'configure)
+                                               (add-before 'build 'path-source-paths
+                                                 (lambda _
+                                                   (substitute* "uwufetch.c"
+                                                     (("(/usr(/local)?)(.*;)"
+                                                       all _ _ rest)
+                                                      (string-append #$output
+                                                                     rest)))))))))
+    (native-inputs (list git))
+    (inputs (list lshw
+                  ;; viu XXX not yet packaged in Guix
+                  xwininfo))
+    (home-page "https://github.com/TheDarkBug/uwufetch")
+    (synopsis "Cutesie *fetch utility")
+    (description
+     "UwUFetch is a system information tool in the lineage of @code{neofetch},
+@code{pfetch}, @{hyfetch}, and the like. It prints ASCII art of your system's
+logo as well as a summary of system information. UwUFetch's unique contribution
+is the uwu-ification of various words used in the description. For example, Guix
+become gUwUix.")
+    (license license:gpl3)))
+
 (define-public screenfetch
   (package
     (name "screenfetch")

base-commit: 4eccb27b4c74a9112cbbad722d85558e9565f20b
-- 
2.39.1