diff mbox series

[bug#60770,v2] gnu: Add docker-registry

Message ID 20230114182600.13639-1-GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#60770,v2] gnu: Add docker-registry | expand

Commit Message

Denis 'GNUtoo' Carikli Jan. 14, 2023, 6:26 p.m. UTC
* gnu/packages/docker.scm (docker-registry): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/docker.scm | 81 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 81 insertions(+)


base-commit: ef0613a81dca73602e702cb5f5444ee94566f983

Comments

Denis 'GNUtoo' Carikli Jan. 23, 2023, 6:55 p.m. UTC | #1
Hi again,

For this patch I checked if there were bundled dependencies with the
'guix import go -r github.com/docker/distribution' command and it found
nothing.

However the way this software is built it a bit strange and I just
found out that there are still bundled in dependencies.

So I guess that at the minimum we need to review the licenses of the
dependencies as well.

Denis.
Christopher Baines Feb. 17, 2023, 4:23 p.m. UTC | #2
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> writes:

> * gnu/packages/docker.scm (docker-registry): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> ---
>  gnu/packages/docker.scm | 81 +++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 81 insertions(+)

I've gone ahead and pushed this to master now as
46013fccb701ebd6d55a9be3374e4fbbf877e3a2.

There's probably room for improvement in the packaging especially
removing some of the vendored dependencies, but I think this is OK to be
merged.
diff mbox series

Patch

diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 7d109dc94c..58c61ba02e 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -724,3 +724,84 @@  (define-public tini
 processes produced from it are reaped and that signals are properly forwarded.
 Tini is integrated with Docker.")
     (license license:expat)))
+
+(define-public docker-registry
+  (package
+    (name "docker-registry")
+    (version "2.8.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/docker/distribution")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1w8zr97p2c62gm1lrdwqa704ivjsy25ylznrddbbpv63idwdbi9k"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/docker/distribution"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir-to-src
+            (lambda _ (chdir "src/github.com/docker/distribution")))
+          (add-after 'chdir-to-src 'fix-versioning
+            (lambda _
+              ;; The Makefile use git to compute the version and the
+              ;; revision. This requires the .git directory that we don't
+              ;; have anymore in the unpacked source.
+              (substitute* "Makefile" (("^VERSION=\\$\\(.*\\)")
+                                       (string-append "VERSION=v" #$version))
+                           ;; The revision originally used the git hash with .m
+                           ;; appended if there was any local modifications.
+                           (("^REVISION=\\$\\(.*\\)") "REVISION=0"))))
+          (replace 'build
+            (lambda _
+              (invoke "make" "binaries")))
+          (replace 'install
+            (lambda _
+              (let ((bin (string-append #$output "/bin")))
+                (mkdir-p bin)
+                (for-each
+                 (lambda (file)
+                   (install-file (string-append "bin/" file) bin))
+                 '("digest"
+                   "registry"
+                   "registry-api-descriptor-template")))
+              (let ((doc (string-append
+                          #$output "/share/doc/" #$name "-" #$version)))
+                (mkdir-p doc)
+                (for-each
+                 (lambda (file)
+                   (install-file file doc))
+                 '("BUILDING.md"
+                   "CONTRIBUTING.md"
+                   "LICENSE"
+                   "MAINTAINERS"
+                   "README.md"
+                   "ROADMAP.md"))
+                (copy-recursively "docs/" (string-append doc "/docs")))
+              (let ((examples
+                     (string-append
+                      #$output "/share/doc/" #$name "-" #$version
+                      "/registry-example-configs")))
+                (mkdir-p examples)
+                (for-each
+                 (lambda (file)
+                   (install-file (string-append "cmd/registry/" file) examples))
+                 '("config-cache.yml"
+                   "config-example.yml"
+                   "config-dev.yml")))))
+      (delete 'install-license-files))))
+  (home-page "https://github.com/docker/distribution")
+  (synopsis "Docker registry server and associated tools")
+  (description "The Docker registry server enable you to host your own
+docker registry. With it, there is also two other utilities:
+@itemize
+@item The digest utility is a tool that generates checksums compatibles with
+various docker manifest files.
+@item The registry-api-descriptor-template is a tool for generating API
+specifications from the docs/spec/api.md.tmpl file.
+@end itemize")
+  (license license:asl2.0)))