diff mbox series

[bug#59758] gnu: Add dislocker.

Message ID 13dcrROCOAZUMAyeACm23prm8ws3D8N1muEl4H76Bm4ExuaDS7YUESqMssqd9JU60lUiIHGzftJ0ZMqR22SqkJs31EV3s-wuTbgX027L2Ac=@protonmail.com
State New
Headers show
Series [bug#59758] gnu: Add dislocker. | expand

Commit Message

phodina Dec. 2, 2022, 4:52 a.m. UTC
Hi,

here's a tool that allows you to access Bitlocker using Fuse.

----
Petr

Comments

Ludovic Courtès Jan. 8, 2023, 11:10 a.m. UTC | #1
Hi,

phodina <phodina@protonmail.com> skribis:

> From d237aca245c0868df016ffa9ac49b7b3f1af11cc Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 13 Jan 2022 13:24:23 +0100
> Subject: [PATCH] gnu: Add dislocker.
>
> * gnu/packages/linux.scm (dislocker): New variable.
> +    (version "0.7.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri
> +               "https://github.com/Aorimn/dislocker/archive/refs/tags/v0.7.3.tar.gz")

This auto-generated tarball changes over time, as reported by ‘guix
lint’.  Could you use ‘git-fetch’ instead?

> +    (build-system cmake-build-system)
> +    (arguments '(#:tests? #f))

Please avoid disabling tests.  If you really have to, add a short
comment explaining why it has to be disabled.

> +    (synopsis "FUSE driver to read/write Windows BitLocker drives")
> +    (description
> +     "This package provides means to to read BitLocker encrypted
> +         partitions. Write functionality is also provided but check the README.")

Indentation is off.  :-)

Could you send an updated patch?

Thanks,
Ludo’.
diff mbox series

Patch

From d237aca245c0868df016ffa9ac49b7b3f1af11cc Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 13 Jan 2022 13:24:23 +0100
Subject: [PATCH] gnu: Add dislocker.

* gnu/packages/linux.scm (dislocker): New variable.

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c417fb600..c398881b44 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2167,6 +2167,26 @@  (define-public ddate
 by Robert Shea and Robert Anton Wilson.")
     (license license:public-domain)))
 
+(define-public dislocker
+  (package
+    (name "dislocker")
+    (version "0.7.3")
+    (source (origin
+              (method url-fetch)
+              (uri
+               "https://github.com/Aorimn/dislocker/archive/refs/tags/v0.7.3.tar.gz")
+              (sha256
+               (base32 "1rn1nvcavpiqpl0g1vfbm5b0w757f4cxcpg0ys3vvwj4gibpalld"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #f))
+    (inputs (list fuse mbedtls-apache))
+    (home-page "https://github.com/Aorimn/dislocker")
+    (synopsis "FUSE driver to read/write Windows BitLocker drives")
+    (description
+     "This package provides means to to read BitLocker encrypted
+         partitions. Write functionality is also provided but check the README.")
+    (license license:gpl2+)))
+
 (define-public fbset
   (package
     (name "fbset")