diff mbox series

[bug#52094] gnu: Add speedometer.

Message ID PU1PR01MB21552B429089FAB97E9C08B08D629@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State New
Headers show
Series [bug#52094] gnu: Add speedometer. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 25, 2021, 8:56 a.m. UTC
* gnu/packages/networking.scm (speedometer): New variable.
---
 gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)


base-commit: 4fd6aabeaabae9184407276f3ae2436284bbcf63

Comments

Maxim Cournoyer Jan. 4, 2023, 12:48 a.m. UTC | #1
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> writes:

> * gnu/packages/networking.scm (speedometer): New variable.
> ---
>  gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index b583d2531f..2e0ccf62bb 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -44,6 +44,7 @@
>  ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
>  ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
>  ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
> +;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -4208,6 +4209,35 @@ on hub/switched networks.  It is based on @acronym{ARP} packets, it will send
>     (home-page "https://github.com/netdiscover-scanner/netdiscover")
>     (license license:gpl3+)))
>  
> +(define-public speedometer
> +  (package
> +    (name "speedometer")
> +    (version "2.8")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "Speedometer" version))
> +       (sha256
> +        (base32 "0qgpjmahy0wlfszqxg0067ck2xab5k6j42d0ifxg1j281yqnm9bx"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'fix-script
> +           (lambda _
> +             (substitute* "setup.py"
> +               (("'scripts': \\['speedometer.py'\\],")
> +                "'packages': ['.'],")))))
> +       #:python ,python-2))
> +    (propagated-inputs
> +     `(("python2-urwid" ,python2-urwid)))

Thanks for this contribution!

Unfortunately, depending on python2-urwid is a problem; we are trying to
purge Python 2 packages from Guix so do not want to add new ones.

Since the latest version is Speedometer 2.8 - 2011-12-08, according to
[0], I think it's fair to say that it is unmaintained and refuse adding
it to our collection on this basis.

I'll close the issue; feel free to send a Python 3 version if and when
it becomes a thing.

[0]  https://excess.org/speedometer/

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b583d2531f..2e0ccf62bb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -44,6 +44,7 @@ 
 ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4208,6 +4209,35 @@  on hub/switched networks.  It is based on @acronym{ARP} packets, it will send
    (home-page "https://github.com/netdiscover-scanner/netdiscover")
    (license license:gpl3+)))
 
+(define-public speedometer
+  (package
+    (name "speedometer")
+    (version "2.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Speedometer" version))
+       (sha256
+        (base32 "0qgpjmahy0wlfszqxg0067ck2xab5k6j42d0ifxg1j281yqnm9bx"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-script
+           (lambda _
+             (substitute* "setup.py"
+               (("'scripts': \\['speedometer.py'\\],")
+                "'packages': ['.'],")))))
+       #:python ,python-2))
+    (propagated-inputs
+     `(("python2-urwid" ,python2-urwid)))
+    (home-page "https://excess.org/speedometer/")
+    (synopsis "Measure and display the rate of data across a network connection")
+    (description
+     "Console monitor of the rate of data across a network connection or data
+being stored in a file.")
+    (license license:lgpl2.1+)))
+
 (define-public putty
   (package
     (name "putty")