diff mbox series

[bug#59704,1/1] services: wireguard: Use the parameterized wireguard package.

Message ID 20221129233929.28696-1-eu@euandre.org
State New
Headers show
Series [bug#59704,1/1] services: wireguard: Use the parameterized wireguard package. | expand

Commit Message

EuAndreh Nov. 29, 2022, 11:39 p.m. UTC
* gnu/services/vpn.scm (wireguard-activation): Use the "wg" binary from
  the package given to <wireguard-configuration>.
---

Notes:
    As of now, there is no other reference to the global "wireguard-tools"
    package in the gnu/services/vpn.scm file.

 gnu/services/vpn.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

宋文武 Dec. 9, 2022, 2:54 a.m. UTC | #1
EuAndreh <eu@euandre.org> writes:

> * gnu/services/vpn.scm (wireguard-activation): Use the "wg" binary from
>   the package given to <wireguard-configuration>.
> ---
>
> Notes:
>     As of now, there is no other reference to the global "wireguard-tools"
>     package in the gnu/services/vpn.scm file.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index def381987b..7b3bb8903c 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -833,7 +833,7 @@  (define (peer->config peer)
 
 (define (wireguard-activation config)
   (match-record config <wireguard-configuration>
-    (private-key)
+    (private-key wireguard)
     #~(begin
         (use-modules (guix build utils)
                      (ice-9 popen)
@@ -842,7 +842,7 @@  (define (wireguard-activation config)
         (unless (file-exists? #$private-key)
           (let* ((pipe
                   (open-input-pipe (string-append
-                                    #$(file-append wireguard-tools "/bin/wg")
+                                    #$(file-append wireguard "/bin/wg")
                                     " genkey")))
                  (key (read-line pipe)))
             (call-with-output-file #$private-key