Message ID | CAE=cykHg=hmy575HjPqbJ8g832+_+LdcZp8J5K7Ly+A7WKebXA@mail.gmail.com |
---|---|
State | New |
Headers | show |
Series | [bug#59594] gnu: i2pd: update to 2.44 | expand |
Heya,
On Fri Nov 25, 2022 at 5:34 PM GMT, Iska Magg wrote:
> this is my first patch, please tell if anything is wrong.
It looks like this patch came from git diff? Please use these instructions
instead :)
<https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html>
-- (
merge 59593 59594 thanks Hi! Iska Magg 写道: > this is my first patch, Thanks! ♥ > please tell if anything is wrong. The diff itself looks good, although I haven't tested it. Sending a ‘real’ patch like ( suggests will include the commit message, missing here. That will make it easier for reviewers to apply. You seem to have sent this mail twice: https://issues.guix.gnu.org/59593 https://issues.guix.gnu.org/59594 The commands at the top of this mail have merged the two bug numbers into one. Kind regards, T G-R
Iska Magg <iskamagg@gmail.com> writes: > diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm > index 2320250148..2e8c1d085d 100644 > --- a/gnu/packages/i2p.scm > +++ b/gnu/packages/i2p.scm > @@ -32,7 +32,7 @@ (define-module (gnu packages i2p) > (define-public i2pd > (package > (name "i2pd") > - (version "2.41.0") > + (version "2.44.0") > (source > (origin > (method git-fetch) > @@ -41,7 +41,7 @@ (define-public i2pd > (commit version))) > (file-name (git-file-name name version)) > (sha256 > - (base32 "0kh03lb4m8fvlfvq06d4hgwmk43pk7yp7n7y36kb2vplhrjrn2kx")))) > + (base32 "0fwaalfxqdahgvx5rfkvdmf6gl10w328a18ddhyn5kvpmp9x7fgl")))) > (build-system cmake-build-system) > (inputs > (list boost miniupnpc openssl zlib)) This looks good to me, I've added a changelog entry to the commit message and pushed to master as 037687ccc81d59613a7c023a49793670d7087c71. Thanks, Chris
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm index 2320250148..2e8c1d085d 100644 --- a/gnu/packages/i2p.scm +++ b/gnu/packages/i2p.scm @@ -32,7 +32,7 @@ (define-module (gnu packages i2p) (define-public i2pd (package (name "i2pd") - (version "2.41.0") + (version "2.44.0") (source (origin (method git-fetch) @@ -41,7 +41,7 @@ (define-public i2pd (commit version))) (file-name (git-file-name name version)) (sha256 - (base32 "0kh03lb4m8fvlfvq06d4hgwmk43pk7yp7n7y36kb2vplhrjrn2kx")))) + (base32 "0fwaalfxqdahgvx5rfkvdmf6gl10w328a18ddhyn5kvpmp9x7fgl")))) (build-system cmake-build-system) (inputs (list boost miniupnpc openssl zlib))