diff mbox series

[bug#59664] gnu: Add tuxedo-keyboard.

Message ID 20221128221758.6760-1-db@minikn.xyz
State New
Headers show
Series [bug#59664] gnu: Add tuxedo-keyboard. | expand

Commit Message

Demis Balbach Nov. 28, 2022, 10:17 p.m. UTC
* gnu/packages/linux.scm (tuxedo-keyboard): New variable.
---
 gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ludovic Courtès Dec. 5, 2022, 4:39 p.m. UTC | #1
Demis Balbach <db@minikn.xyz> skribis:

> * gnu/packages/linux.scm (tuxedo-keyboard): New variable.

[...]

> +    (license license:gpl3)))

Change it to ‘gpl3+’ because source file headers carry the “or any later
version” wording.

Thanks,
Ludo’.
Demis Balbach Dec. 5, 2022, 7:30 p.m. UTC | #2
>
> Change it to ‘gpl3+’ because source file headers carry the “or any later
> version” wording.
>
> Thanks,
> Ludo’.
>

Hello,

I'm not familiar with the procecure. Why exactly did you close this
issue? Do I need to open a new one with altered patch?
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2e1da21800..6a6de13a15 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1405,6 +1406,32 @@  (define-public librem-ec-acpi-linux-module
 and the notification, WiFi, and Bluetooth LED.")
     (license license:gpl2)))
 
+(define-public tuxedo-keyboard
+  (package
+    (name "tuxedo-keyboard")
+    (version "3.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tuxedocomputers/tuxedo-keyboard.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17n14yh55yrxx4qbx4ph9drbzx2ll4kdsfmlngrdgizhyzk7z7zv"))))
+    (build-system linux-module-build-system)
+    (arguments
+     (list #:tests? #f))                ; no test suite
+    (home-page "https://github.com/tuxedocomputers/tuxedo-keyboard")
+    (synopsis "Linux kernel modules to control keyboard on most Tuxedo computers")
+    (description
+     "This packages provides the @code{tuxedo_keyboard}, @code{tuxedo_io}, @code{clevo_wmi}
+@acronym{WMI, Windows Management Engine} and the @code{clevo_acpi} @acronym{ACPI, Advanced
+Configuration and Power Interface} kernel modules to control the keyboard on most Tuxedo
+computers. Only white backlight only models are currently not supported. The @code{tuxedo_io}
+module is also needed for the @code{tuxedo-control-center} (short tcc) package.")
+    (license license:gpl3)))
+
 (define-public ec
   (package
     (name "ec")