diff mbox series

[bug#59661,v2,2/3] install: Add missing e2fsprogs utility.

Message ID 20221204044347.23147-2-maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#59661,v2,1/3] system: Rename and move %base-packages-disk-utilities. | expand

Commit Message

Maxim Cournoyer Dec. 4, 2022, 4:43 a.m. UTC
* gnu/system/install.scm (%installer-disk-utilities): Add e2fsprogs.
---
 gnu/system/install.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Dec. 4, 2022, 4:34 p.m. UTC | #1
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> * gnu/system/install.scm (%installer-disk-utilities): Add e2fsprogs.

LGTM!

e2fsprogs binaries are indeed missing from $PATH in
guix-system-install-1.4.0rc1.*.iso; I’ll cherry-pick it on
‘version-1.4.0’.

What I don’t get is that our manual installation tests should have
caught this issue because they use ‘mkfs.ext4’ and expect to have it in
$PATH.  I’ll take a look…

Ludo’.
Ludovic Courtès Dec. 4, 2022, 5:28 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> skribis:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> * gnu/system/install.scm (%installer-disk-utilities): Add e2fsprogs.
>
> LGTM!
>
> e2fsprogs binaries are indeed missing from $PATH in
> guix-system-install-1.4.0rc1.*.iso; I’ll cherry-pick it on
> ‘version-1.4.0’.
>
> What I don’t get is that our manual installation tests should have
> caught this issue because they use ‘mkfs.ext4’ and expect to have it in
> $PATH.  I’ll take a look…

Got it: Mathieu worked around it in
0f66ef9aa99d2043abccbc80d858bdeca57534ac by explicitly adding e2fsprogs
and the installation system used by the tests:

  commit 0f66ef9aa99d2043abccbc80d858bdeca57534ac
  Author: Mathieu Othacehe <othacehe@gnu.org>
  Date:   Fri Sep 30 15:19:36 2022 +0200

      tests: install: Fix iso-image-installer test.

      This is a follow-up of: 45eac6cdf5c8d9d7b0c564b105c790d2d2007799.
      It fixes the following error:

      + mkfs.ext4 -L my-root /dev/vda2
      sh: line 12: mkfs.ext4: command not found

      * gnu/tests/install.scm (%test-iso-image-installer): Add e2fsprogs to the
      appended packages.

We should be able to revert this commit once the installer provides
e2fsprogs by default.

Thanks,
Ludo’.
Maxim Cournoyer Dec. 5, 2022, 4:44 p.m. UTC | #3
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

> Ludovic Courtès <ludo@gnu.org> skribis:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>>
>>> * gnu/system/install.scm (%installer-disk-utilities): Add e2fsprogs.
>>
>> LGTM!
>>
>> e2fsprogs binaries are indeed missing from $PATH in
>> guix-system-install-1.4.0rc1.*.iso; I’ll cherry-pick it on
>> ‘version-1.4.0’.
>>
>> What I don’t get is that our manual installation tests should have
>> caught this issue because they use ‘mkfs.ext4’ and expect to have it in
>> $PATH.  I’ll take a look…
>
> Got it: Mathieu worked around it in
> 0f66ef9aa99d2043abccbc80d858bdeca57534ac by explicitly adding e2fsprogs
> and the installation system used by the tests:
>
>   commit 0f66ef9aa99d2043abccbc80d858bdeca57534ac
>   Author: Mathieu Othacehe <othacehe@gnu.org>
>   Date:   Fri Sep 30 15:19:36 2022 +0200
>
>       tests: install: Fix iso-image-installer test.
>
>       This is a follow-up of: 45eac6cdf5c8d9d7b0c564b105c790d2d2007799.
>       It fixes the following error:
>
>       + mkfs.ext4 -L my-root /dev/vda2
>       sh: line 12: mkfs.ext4: command not found
>
>       * gnu/tests/install.scm (%test-iso-image-installer): Add e2fsprogs to the
>       appended packages.
>
> We should be able to revert this commit once the installer provides
> e2fsprogs by default.

I applied this series, reverted 0f66ef9aa99d2043abccbc80d858bdeca57534ac
as suggested above, ran:

--8<---------------cut here---------------start------------->8---
make check-system TESTS=iso-image-installer
--8<---------------cut here---------------end--------------->8---

And pushed!

Closing.
diff mbox series

Patch

diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index d34d974338..f6f1923121 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -471,6 +471,7 @@  (define %installer-disk-utilities
         cryptsetup mdadm
         dosfstools
         btrfs-progs
+        e2fsprogs
         f2fs-tools
         jfsutils
         xfsprogs))