diff mbox series

[bug#59623] gnu: Add bgpq3.

Message ID 20221127022727.28672-1-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59623] gnu: Add bgpq3. | expand

Commit Message

Felix Lechner Nov. 27, 2022, 2:27 a.m. UTC
* gnu/packages/networking.scm (bgpq3): New variable.
---
 gnu/packages/networking.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: c457c715a83358fa1557f703b1e459435fb1a259

Comments

Tobias Geerinckx-Rice Dec. 2, 2022, 7:44 p.m. UTC | #1
Hi Felix,

Felix Lechner via Guix-patches via 写道:
> * gnu/packages/networking.scm (bgpq3): New variable.

Thanks!

> +(define-public bgpq3
> +  (let ((commit "9e46c66cff0c0cdcca653141b1664dbf6f9370ed")
> +        (revision "0"))

I dropped this and referred directly to the

> +      (version (git-version "0.1.36.1" revision commit))

tag, only because that's the current convention.  The result is 
equivalent.

> +      (arguments
> +       '(#:phases
> +         (modify-phases %standard-phases
> +           (delete 'check))))

Similarly, we use

  #:tests? #f                 ; no test suite

instead.  No functional change.

> +      (home-page "http://snar.spb.ru/prog/bgpq3/")

Self-signed certificates are the best certificates!  :-/

> +      (synopsis "Generate BGP filters from the Internet Routing 
> Registry system")
> +      (description
> +       "This program generates BGP routing filters from data in 
> the Internet
> +Routing Registry system, including the Routing Assets Database 
> that is operated
> +by the Merit Network at the University of Michigan.  Examples 
> are prefix-lists,
> +extended access-lists, policy-statement terms and as-path 
> lists.  It is an
> +essential peering tool for exchange operators.")

I took the liberty of expanding this a bit, mostly by adding 
mark-up and including the search terms ‘IRR’ and ‘RADB’.

I don't dispute its accuracy, but ‘an essential peering tool’ runs 
afoul of Guix's policy of toning down marketing language.  I did 
keep the reference to IXes though.

> +      (license license:bsd-2))))

As noted on IRC, there are two BSD-3 files in this package.  Both 
the author & GitHub seem to have missed this.  I've submitted a 
bug report.

Pushed with the above changes as 
9ef6286bc3f6ed780606d3c2089aed7ff73074c3.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f5276e330e..f5e0760878 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2998,6 +2998,37 @@  (define-public quagga
     (home-page "https://www.nongnu.org/quagga/")
     (license license:gpl2+)))
 
+(define-public bgpq3
+  (let ((commit "9e46c66cff0c0cdcca653141b1664dbf6f9370ed")
+        (revision "0"))
+    (package
+      (name "bgpq3")
+      (version (git-version "0.1.36.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/snar/bgpq3")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0768hihx7idmn2dk8ii21m0dm052amlnfpqq53vsfaapb60n1smc"))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (delete 'check))))
+      (native-inputs (list python-markdown))
+      (home-page "http://snar.spb.ru/prog/bgpq3/")
+      (synopsis "Generate BGP filters from the Internet Routing Registry system")
+      (description
+       "This program generates BGP routing filters from data in the Internet
+Routing Registry system, including the Routing Assets Database that is operated
+by the Merit Network at the University of Michigan.  Examples are prefix-lists,
+extended access-lists, policy-statement terms and as-path lists.  It is an
+essential peering tool for exchange operators.")
+      (license license:bsd-2))))
+
 (define-public thc-ipv6
   (let ((revision "0")
         (commit "4bb72573e0950ce6f8ca2800a10748477020029e"))