diff mbox series

[bug#59436] gnu: Add emacs-ebuku.

Message ID 20221121064654.8438-1-hako@ultrarare.space
State New
Headers show
Series [bug#59436] gnu: Add emacs-ebuku. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Hilton Chain Nov. 21, 2022, 6:46 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ebuku): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 97bbdedfd316694a2f7ed17d8b31101c27329c80

Comments

Christopher Baines Nov. 22, 2022, 9:41 a.m. UTC | #1
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ebuku): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

I changed the revision to 0 (rather than 79), this number is usually
incremented when changing the commit, and it's probably conventional to
start from 0.

I've gone ahead and pushed to master as
d54febb86ff71a93a8a62957658512ca4727f89d.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a92ab71a97..62fb3a092f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13325,6 +13325,30 @@  (define-public emacs-ebuild-mode
 news items, openrc and runscripts.")
     (license license:gpl2+)))
 
+(define-public emacs-ebuku
+  ;; Upstream has no tagged release.
+  (let ((revision "79")
+        (commit "5b8bf34b8ea5d05f0b8dfc12bfea825f9cffbeda"))
+    (package
+      (name "emacs-ebuku")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/flexibeast/ebuku")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "04733lqa6z3kmdjcgdi58q3wrqan2qib43rvjw51qc739fwmwb5y"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/flexibeast/ebuku")
+      (synopsis "Emacs interface to the buku Web bookmark manager")
+      (description
+       "Ebuku provides a basic interface to the @code{buku} Web bookmark
+manager.")
+      (license license:gpl3+))))
+
 (define-public emacs-evil
   ;; Commit message claims this is 1.15.0, but there's no tag for it, so we
   ;; use full git-version instead