diff mbox series

[bug#59446] gnu: cl-parachute: Update to 1.5.0-0.8bc3e1b.

Message ID 20221121125458.54897-1-paul@apatience.com
State New
Headers show
Series [bug#59446] gnu: cl-parachute: Update to 1.5.0-0.8bc3e1b. | expand

Commit Message

Paul A. Patience Nov. 21, 2022, 12:55 p.m. UTC
* gnu/packages/lisp-check.scm (sbcl-parachute): Update to
1.5.0-0.8bc3e1b. (The previous version was actually also 1.5.0, not
1.1.1.)
[file-name]: Rename to cl-parachute.
[inputs]: Add sbcl-trivial-custom-debugger.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-custom-debugger)
[arguments]: New field.
[native-inputs]: Remove field.
---
Hi,

I'm not sure how to fix the circular dependency between
trivial-custom-debugger and parachute — I suppose that would involve creating
a package for trivial-custom-debugger with tests disabled specifically for
parachute.
However, I saw elsewhere in lisp-xyz.scm disabled tests because of circular
dependencies, so I did the same.

Best regards,
Paul

 gnu/packages/lisp-check.scm | 15 ++++++++-------
 gnu/packages/lisp-xyz.scm   |  8 ++++++--
 2 files changed, 14 insertions(+), 9 deletions(-)

--
2.38.0

Comments

Guillaume Le Vaillant Nov. 22, 2022, 9:11 a.m. UTC | #1
Patch pushed as 0435469669ad1f8d02c9580a5eaea6d89bfea66e.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 7002cd9d92..58b79ba6e5 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -634,11 +634,11 @@  (define-public cl-nst
   (sbcl-package->cl-source-package sbcl-nst))

 (define-public sbcl-parachute
-  (let ((commit "86563473dc23fb1277d35a3ad2c911a6c8e5b0da")
-        (revision "1"))
+  (let ((commit "8bc3e1b5a1808341967aeb89516f9fab23cd1d9e")
+        (revision "0"))
     (package
       (name "sbcl-parachute")
-      (version (git-version "1.1.1" revision commit))
+      (version (git-version "1.5.0" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -646,13 +646,14 @@  (define-public sbcl-parachute
           (git-reference
            (url "https://github.com/Shinmera/parachute")
            (commit commit)))
-         (file-name (git-file-name name version))
+         (file-name (git-file-name "cl-parachute" version))
          (sha256
-          (base32
-           "026crl465xqh3fnskfd4c1sxa9c33dfy702cf3l5apbjyj1dg20n"))))
+          (base32 "0cppp1sp9xqkgxgkwidhqzlsj03ywnar7z9mzwcliww8y0kv5555"))))
       (build-system asdf-build-system/sbcl)
       (inputs
-       (list sbcl-documentation-utils sbcl-form-fiddle))
+       (list sbcl-documentation-utils
+             sbcl-form-fiddle
+             sbcl-trivial-custom-debugger))
       (synopsis "Extensible and cross-compatible testing framework for Common Lisp")
       (description
        "Parachute is a simple-to-use and extensible testing framework.
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a0fb302ded..ae05f78534 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -24215,8 +24215,12 @@  (define-public sbcl-trivial-custom-debugger
          (sha256
           (base32 "1iri5wsp9sc1f5q934cj87zd79r5dc8fda0gl7x1pz95v0wx28yk"))))
       (build-system asdf-build-system/sbcl)
-      (native-inputs
-       (list sbcl-parachute))
+      (arguments
+       '(;; FIXME: Tests disabled because of a circular dependency between
+         ;; trivial-custom-debugger and parachute.
+         #:tests? #f))
+      ;;(native-inputs
+      ;; (list sbcl-parachute))
       (home-page "https://github.com/phoe/trivial-custom-debugger/")
       (synopsis "Allow arbitrary functions as the standard Lisp debugger")
       (description