diff mbox series

[bug#59392] scripts: Use translations for guix.pot for service descriptions.

Message ID 87leo6muf2.fsf@pelzflorian.de
State New
Headers show
Series [bug#59392] scripts: Use translations for guix.pot for service descriptions. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

pelzflorian (Florian Pelz) Nov. 19, 2022, 10:49 p.m. UTC
Previously, service descriptions appeared in both guix.pot and
packages.pot, but only translations of packages.pot were used.
Now, translations are only done with guix.pot.

This is better, because translators are more likely to translate
guix.pot, and is also easier, because files in gnu/{home/,}services
need to be in po/guix/POTFILES.in anyway and po/guix/Makevars
already acts on the 'description' keyword because of lint checkers.

* guix/scripts/home.scm (service-type-description-string):
Use translations from guix.pot.
* guix/scripts/system/search.scm (service-type-description-string)
(service-type->recutils): Likewise.
* po/packages/POTFILES.in: Move files in gnu/services to ...
* po/guix/POTFILES.in: ... here.
---
P.S. I hope the subject line `scripts: …' is correct, instead of
`nls: …'.

 guix/scripts/home.scm          | 2 +-
 guix/scripts/system/search.scm | 4 ++--
 po/guix/POTFILES.in            | 4 ++++
 po/packages/POTFILES.in        | 5 -----
 4 files changed, 7 insertions(+), 8 deletions(-)


base-commit: bb04b5e0ceb606c8d33d53bf06f7fc8855a2c56b

Comments

pelzflorian (Florian Pelz) Nov. 20, 2022, 1 p.m. UTC | #1
Forgot to put translation team in Cc.

No change to Julien’s proxy repository guix-translations.git is needed
as far as I can tell.

Regards,
Florian
Julien Lepiller Nov. 20, 2022, 1:07 p.m. UTC | #2
LGTM :)

Le 20 novembre 2022 14:00:15 GMT+01:00, "pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> a écrit :
>Forgot to put translation team in Cc.
>
>No change to Julien’s proxy repository guix-translations.git is needed
>as far as I can tell.
>
>Regards,
>Florian
pelzflorian (Florian Pelz) Nov. 20, 2022, 3:09 p.m. UTC | #3
Julien Lepiller <julien@lepiller.eu> writes:
> LGTM :)

Thank you!  Pushed as da6c6763fa72585a1df3021781f8d33c3b64dcc8.
Closing.

Regards,
Florian
diff mbox series

Patch

diff --git a/guix/scripts/home.scm b/guix/scripts/home.scm
index 754001a5b8..1c481ccf91 100644
--- a/guix/scripts/home.scm
+++ b/guix/scripts/home.scm
@@ -705,7 +705,7 @@  (define service-type-name*
 (define (service-type-description-string type)
   "Return the rendered and localised description of TYPE, a service type."
   (and=> (service-type-description type)
-         (compose texi->plain-text P_)))
+         (compose texi->plain-text G_)))
 
 (define %service-type-metrics
   ;; Metrics used to estimate the relevance of a search result.
diff --git a/guix/scripts/system/search.scm b/guix/scripts/system/search.scm
index 44f00194cd..d978884518 100644
--- a/guix/scripts/system/search.scm
+++ b/guix/scripts/system/search.scm
@@ -127,7 +127,7 @@  (define highlighting*
                (parameterize ((%text-width width*))
                  (texi->plain-text
                   (string-append "description: "
-                                 (or (and=> (service-type-description type) P_)
+                                 (or (and=> (service-type-description type) G_)
                                      ""))))
                #\newline)))))
 
@@ -144,7 +144,7 @@  (define highlighting*
 (define (service-type-description-string type)
   "Return the rendered and localised description of TYPE, a service type."
   (and=> (service-type-description type)
-         (compose texi->plain-text P_)))
+         (compose texi->plain-text G_)))
 
 (define %service-type-metrics
   ;; Metrics used to estimate the relevance of a search result.
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index 228ce04240..7009fc756c 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -4,10 +4,14 @@  gnu.scm
 gnu/packages.scm
 gnu/services.scm
 gnu/system.scm
+gnu/services/base.scm
+gnu/services/certbot.scm
 gnu/services/configuration.scm
+gnu/services/file-sharing.scm
 gnu/services/networking.scm
 gnu/services/shepherd.scm
 gnu/services/samba.scm
+gnu/services/version-control.scm
 gnu/home/services.scm
 gnu/home/services/ssh.scm
 gnu/home/services/symlink-manager.scm
diff --git a/po/packages/POTFILES.in b/po/packages/POTFILES.in
index 398f9adfdf..32d34d6456 100644
--- a/po/packages/POTFILES.in
+++ b/po/packages/POTFILES.in
@@ -57,8 +57,3 @@  gnu/packages/webkit.scm
 gnu/packages/web.scm
 gnu/packages/wordnet.scm
 gnu/packages/xiph.scm
-gnu/services/base.scm
-gnu/services/certbot.scm
-gnu/services/file-sharing.scm
-gnu/services/networking.scm
-gnu/services/version-control.scm