diff mbox series

[bug#59352] gnu: Add emacs-org-tree-slide.

Message ID 87v8ncbp09.fsf@colimite.fr
State New
Headers show
Series [bug#59352] gnu: Add emacs-org-tree-slide. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sergiu Ivanov Nov. 18, 2022, 9:15 a.m. UTC
Hello,

Here's a patch adding emacs-org-tree-slide.

It's my second Guix package ever, and I actually enjoyed following the
instructions from the manual for building, linting and styling it. Tell
me if I got it right :D

-
Sergiu

Comments

Nicolas Goaziou Nov. 18, 2022, 9:24 p.m. UTC | #1
Hello,

Sergiu Ivanov <sivanov@colimite.fr> writes:

> Here's a patch adding emacs-org-tree-slide.

Thank you.

> It's my second Guix package ever, and I actually enjoyed following the
> instructions from the manual for building, linting and styling it. Tell
> me if I got it right :D

Almost ;) Some comments follow.

> Subject: [PATCH] gnu: Add emacs-org-tree-slide.
>
> ---
>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++


Your commit message is missing a part about the module being modified:

  * gnu/packages/emacs-xyz.scm (emacs-org-tree-slide): New variable.


> +(define-public emacs-org-tree-slide
> +  (package
> +    (name "emacs-org-tree-slide")
> +    (version "20221016.1623")

Latest version is 2.8.18, the version above is a fancy date tag from
MELPA unstable.

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://melpa.org/packages/org-tree-slide-"
> +                           version ".el"))

We don't use MELPA as upstream because it doesn't guarantee the tarball
will always be available. Use GitHub as upstream instead.

> +    (synopsis "Emacs minor mode for giving presentations with Org-mode")

Nitpick: Org-mode -> Org mode.

> +    (description
> +     "This package provides the Org minor mode @code{org-tree-slide} which
> +allows for using an Org-mode document in presentations by
> +progressively revealing individual subtrees of the document.
> +org-tree-slide shows and hides parts of the Org buffer by narrowing.")

I suggest:

  Org Tree Slide is a minor mode for using an Org document in
  presentations by progressively revealing individual subtrees of the
  document.

> +    (license license:gpl3)))

License is actually gpl3+ because the license in the org-tree-slide.el
file mention "or (at your option), any later version".

Could you send an updated patch?

Well done BTW!

Regards,
diff mbox series

Patch

From 6f53bc504923028c9cae3619192db976a25af4a4 Mon Sep 17 00:00:00 2001
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Fri, 18 Nov 2022 10:11:53 +0100
Subject: [PATCH] gnu: Add emacs-org-tree-slide.

---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fe0d9f1dc9..33158f54eb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -118,6 +118,7 @@ 
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
+;;; Copyright © 2022 Sergiu Ivanov <sivanov@colimite.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5900,6 +5901,27 @@  (define-public emacs-stripe-buffer
 tables.")
     (license license:gpl2+)))
 
+(define-public emacs-org-tree-slide
+  (package
+    (name "emacs-org-tree-slide")
+    (version "20221016.1623")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://melpa.org/packages/org-tree-slide-"
+                           version ".el"))
+       (sha256
+        (base32 "0pzq43l80i7p1w0ph5az1nxpwpl50ahmi7ql22ai31x7rh1a44fi"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/takaxp/org-tree-slide")
+    (synopsis "Emacs minor mode for giving presentations with Org-mode")
+    (description
+     "This package provides the Org minor mode @code{org-tree-slide} which
+allows for using an Org-mode document in presentations by
+progressively revealing individual subtrees of the document.
+org-tree-slide shows and hides parts of the Org buffer by narrowing.")
+    (license license:gpl3)))
+
 (define-public emacs-org-beautify-theme
   ;; Latest release (0.4) is not tagged, use commit hash.
   (let ((commit "df6a1114fda313e1689363e196c8284fbe2a2738")
-- 
2.38.1