diff mbox series

[bug#59225] gnu: Modify python-qtconsole use python-pyqt-without-webkit.

Message ID 20221112204526.20027-1-raingloom@riseup.net
State New
Headers show
Series [bug#59225] gnu: Modify python-qtconsole use python-pyqt-without-webkit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Csepp Nov. 12, 2022, 8:45 p.m. UTC
From: Csepp <raingloom@riseup.net>

* gnu/packages/python-xyz.scm (python-qtconsole)[propagated-inputs]:
  Use python-pyqt-without-webkit.
---
This makes it possible to use Jupyter on i686, where qtwebkit is currently failing to build due to running out of memory.

 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Nov. 15, 2022, 9:17 a.m. UTC | #1
I changed python-pyqt-without-webkit to python-pyqt-without-qtwebkit and
pushed the patch. Thanks!
Csepp Nov. 15, 2022, 1:56 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> [[PGP Signed Part:Undecided]]
> I changed python-pyqt-without-webkit to python-pyqt-without-qtwebkit and
> pushed the patch. Thanks!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c2f9d7b73..a314591d4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13884,8 +13884,8 @@  (define-public python-qtconsole
                (("def test_other_output") "def _test_other_output")))))))
     (propagated-inputs
      (list python-ipykernel python-ipython-genutils python-jupyter-client
-           python-jupyter-core python-pygments python-pyqt python-pyzmq
-           python-qtpy python-traitlets))
+           python-jupyter-core python-pygments python-pyqt-without-webkit
+           python-pyzmq python-qtpy python-traitlets))
     (native-inputs
      (list python-flaky python-pytest python-pytest-qt))
     (home-page "https://jupyter.org")