diff mbox series

[bug#58670,1/2] gnu: yoshimi: Update to 2.2.2.1

Message ID MW4UtQbCHyW1MMu9YZmw3Y6NUZlRqHlY8OxMUUdc7YTiU4uzFkviyEgTGzr8iZwR_VLp06bdXCzdUqh31PPOi9UkL3VvrNRG3-a1TLMbkjU=@proton.me
State New
Headers show
Series [bug#58670,1/2] gnu: yoshimi: Update to 2.2.2.1 | expand

Commit Message

Sughosha Oct. 20, 2022, 8:37 p.m. UTC
Empty Message

Comments

Ludovic Courtès Nov. 8, 2022, 12:54 p.m. UTC | #1
Hi,

Sughosha <Sughosha@proton.me> skribis:

> From 34e7f49c29c1659b1edbf4bcdeeedd01891c05ec Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 20 Oct 2022 21:54:32 +0200
> Subject: [PATCH 1/2] gnu: yoshimi: Update to 2.2.2.1
>
> * gnu/packages/music.scm (yoshimi): Update to 2.2.2.1.

[...]

> From 793e0b3abd7460a52c5a8e810f7b45322d3f84ca Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 20 Oct 2022 22:34:24 +0200
> Subject: [PATCH 2/2] gnu: yoshimi: Fix preset paths and viewing manual
>
> * gnu/packages/music.scm (yoshimi)
> [arguments]: Fix preset paths.
> [propagated-inputs]: Add xdg-utils.

Applied both.  However, I removed this bit:

> +    (propagated-inputs
> +     (list xdg-utils)) ; to view manual

Because we wouldn’t, for example, propagate Emacs with a package that
has an Info manual, or propagate IceCat with a package that has an HTML
manual.  It’s similar here IMO.

Thanks,
Ludo’.
diff mbox series

Patch

From 793e0b3abd7460a52c5a8e810f7b45322d3f84ca Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 20 Oct 2022 22:34:24 +0200
Subject: [PATCH 2/2] gnu: yoshimi: Fix preset paths and viewing manual

* gnu/packages/music.scm (yoshimi)
[arguments]: Fix preset paths.
[propagated-inputs]: Add xdg-utils.
---
 gnu/packages/music.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c1355bfbf4..f69277875a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3060,6 +3060,13 @@  (define-public yoshimi
          ;; Move SSE compiler optimization flags from generic target to
          ;; athlon64 and core2 targets, because otherwise the build would fail
          ;; on non-Intel machines.
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* (list "src/Interface/InterChange.cpp"
+                                "src/Misc/Bank.cpp"
+                                "src/Misc/Config.cpp")
+               (("/usr/share") (string-append (assoc-ref outputs "out")
+                                              "/share")))))
          (add-after 'unpack 'remove-sse-flags-from-generic-target
            (lambda _
              (substitute* "src/CMakeLists.txt"
@@ -3083,6 +3090,8 @@  (define-public yoshimi
        ("zlib" ,zlib)))
     (native-inputs
      (list pkg-config))
+    (propagated-inputs
+     (list xdg-utils)) ; to view manual
     (home-page "http://yoshimi.sourceforge.net/")
     (synopsis "Multi-paradigm software synthesizer")
     (description
-- 
2.38.0