diff mbox series

[bug#55423] : gnu: Add mogan.

Message ID 86o7vut5ck.fsf@163.com
State New
Headers show
Series [bug#55423] : gnu: Add mogan. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao Sept. 5, 2022, 11:41 a.m. UTC
Long time no see.

I updated Mogan to 1.1.0 and switch the source to github.

Comments

Zhu Zihao Sept. 22, 2022, 5:40 a.m. UTC | #1
ping.

Zhu Zihao <all_but_last@163.com> writes:

> [[PGP Signed Part:Undecided]]
>
> Long time no see.
>
> I updated Mogan to 1.1.0 and switch the source to github.
>
> [[End of PGP Signed Part]]
> From f754c24c0945dd2fc17881f37598262b612eee67 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 14 May 2022 22:16:38 +0800
> Subject: [PATCH 1/2] gnu: texmacs: Use G-expression.
>
> * gnu/packages/text-editors.scm (texmacs): Use G-expressions.
> ---
>  gnu/packages/text-editors.scm | 26 +++++++++++++-------------
>  1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
> index 0c30a705b9..8a52e0ef41 100644
> --- a/gnu/packages/text-editors.scm
> +++ b/gnu/packages/text-editors.scm
> @@ -872,19 +872,19 @@ (define-public texmacs
>             qtsvg-5
>             sqlite))
>      (arguments
> -     `(#:tests? #f                      ; no check target
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'fix-icon-directory
> -           (lambda* (#:key outputs #:allow-other-keys)
> -             (let ((out (assoc-ref outputs "out")))
> -               (substitute* "packages/linux/icons.sh"
> -                 (("/usr/share")
> -                  (string-append out "/share"))))))
> -         (add-before 'configure 'gzip-flags
> -           (lambda _
> -             (substitute* "Makefile.in"
> -               (("^GZIP = gzip -f") "GZIP = gzip -f -n")))))))
> +     (list
> +      #:tests? #f                       ; no check target
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'fix-icon-directory
> +            (lambda _
> +              (substitute* "packages/linux/icons.sh"
> +                (("/usr/share")
> +                 (string-append #$output "/share")))))
> +          (add-before 'configure 'gzip-flags
> +            (lambda _
> +              (substitute* "Makefile.in"
> +                (("^GZIP = gzip -f") "GZIP = gzip -f -n")))))))
>      (synopsis "Editing platform with special features for scientists")
>      (description
>       "GNU TeXmacs is a text editing platform which is specialized for
> -- 
> 2.37.2
>
> From bf3c22e5f835725fd700176f0d1b1ec0ac28fe51 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 14 May 2022 22:19:06 +0800
> Subject: [PATCH 2/2] gnu: Add mogan.
>
> * gnu/packages/text-editors.scm (mogan): New variable.
> ---
>  gnu/packages/text-editors.scm | 37 +++++++++++++++++++++++++++++++++++
>  1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
> index 8a52e0ef41..24600b4148 100644
> --- a/gnu/packages/text-editors.scm
> +++ b/gnu/packages/text-editors.scm
> @@ -56,6 +56,7 @@ (define-module (gnu packages text-editors)
>    #:use-module (gnu packages code)
>    #:use-module (gnu packages cpp)
>    #:use-module (gnu packages crates-io)
> +  #:use-module (gnu packages curl)
>    #:use-module (gnu packages datastructures)
>    #:use-module (gnu packages documentation)
>    #:use-module (gnu packages fontutils)
> @@ -895,6 +896,42 @@ (define-public texmacs
>      (license license:gpl3+)
>      (home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
>  
> +(define-public mogan
> +  (package
> +    (inherit texmacs)
> +    (name "mogan")
> +    (version "1.1.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/XmacsLabs/mogan")
> +             (commit (string-append "v" version))))
> +       (sha256
> +        (base32 "0l7irs5w6f1dmzxz2p4c4vxc2w999yxy1qvhbcv5yh3kfbyzrf7z"))))
> +    (inputs
> +     (modify-inputs (package-inputs texmacs)
> +       ;; Replaced by S7 scheme
> +       ;; TODO: Maybe unbundle S7
> +       (delete "guile")
> +       (prepend curl)))
> +    (arguments
> +     (substitute-keyword-arguments (package-arguments texmacs)
> +       ((#:phases orig)
> +        #~(modify-phases #$orig
> +            (replace 'gzip-flags
> +              (lambda _
> +                (substitute* "misc/CMakeLists.txt"
> +                  (("COMMAND gzip" all)
> +                   (string-append all " -n")))))))))
> +    (synopsis "Structural editor delivered by Xmacs Labs")
> +    (description
> +     "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
> +make everyone to enjoy it fluently and develop new feature for everyone to learn
> +and create science and technology.")
> +    (license license:gpl3+)
> +    (home-page "https://gitee.com/XmacsLabs/mogan")))
> +
>  (define-public scintilla
>    (package
>      (name "scintilla")
> -- 
> 2.37.2
Zhu Zihao Nov. 7, 2022, 11:06 a.m. UTC | #2
Closed due to 59102.
diff mbox series

Patch

From bf3c22e5f835725fd700176f0d1b1ec0ac28fe51 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 14 May 2022 22:19:06 +0800
Subject: [PATCH 2/2] gnu: Add mogan.

* gnu/packages/text-editors.scm (mogan): New variable.
---
 gnu/packages/text-editors.scm | 37 +++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 8a52e0ef41..24600b4148 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -56,6 +56,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages code)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-io)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
@@ -895,6 +896,42 @@  (define-public texmacs
     (license license:gpl3+)
     (home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
 
+(define-public mogan
+  (package
+    (inherit texmacs)
+    (name "mogan")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/XmacsLabs/mogan")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0l7irs5w6f1dmzxz2p4c4vxc2w999yxy1qvhbcv5yh3kfbyzrf7z"))))
+    (inputs
+     (modify-inputs (package-inputs texmacs)
+       ;; Replaced by S7 scheme
+       ;; TODO: Maybe unbundle S7
+       (delete "guile")
+       (prepend curl)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments texmacs)
+       ((#:phases orig)
+        #~(modify-phases #$orig
+            (replace 'gzip-flags
+              (lambda _
+                (substitute* "misc/CMakeLists.txt"
+                  (("COMMAND gzip" all)
+                   (string-append all " -n")))))))))
+    (synopsis "Structural editor delivered by Xmacs Labs")
+    (description
+     "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
+make everyone to enjoy it fluently and develop new feature for everyone to learn
+and create science and technology.")
+    (license license:gpl3+)
+    (home-page "https://gitee.com/XmacsLabs/mogan")))
+
 (define-public scintilla
   (package
     (name "scintilla")
-- 
2.37.2