diff mbox series

[bug#58100,v2,1/8] cbqn: Build without singeli.

Message ID 15a1bde90dc5a23d31dca8f7139ecb1d3cffbaed.camel@gmail.com
State New
Headers show
Series [bug#58100,v2,1/8] cbqn: Build without singeli. | expand

Commit Message

Liliana Marie Prikler Oct. 22, 2022, 6:23 p.m. UTC
* gnu/packages/bqn.scm (cbqn)[inputs]: Remove singeli-sources.
[arguments]<#:make-flags: Replace “o3n-singeli” with “o3”.
<#:phases>: Remove “link-singeli”.
---
 gnu/packages/bqn.scm | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)


base-commit: bb2701b9111a3d82a82ceaaf2b22b51ecd8ac21f

Comments

Ludovic Courtès Nov. 6, 2022, 5:39 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/bqn.scm (cbqn)[inputs]: Remove singeli-sources.
> [arguments]<#:make-flags: Replace “o3n-singeli” with “o3”.
> <#:phases>: Remove “link-singeli”.

This series of patches that you sent LGTM!

However, how does it relate to AVX2-specific builds?  Anyhow, as you
suggested in the thread, it’d be a good idea to add a ‘tunable?’
property.

Thanks,
Ludo’.
Liliana Marie Prikler Nov. 6, 2022, 6:25 p.m. UTC | #2
Am Sonntag, dem 06.11.2022 um 18:39 +0100 schrieb Ludovic Courtès:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/bqn.scm (cbqn)[inputs]: Remove singeli-sources.
> > [arguments]<#:make-flags: Replace “o3n-singeli” with “o3”.
> > <#:phases>: Remove “link-singeli”.
> 
> This series of patches that you sent LGTM!
> 
> However, how does it relate to AVX2-specific builds?  
IIUC, singeli is some tool that emits avx2-specific opcodes and the
singeli builds of cbqn use that somehw; I admit, I do not completely
understand what's going on on their side.

> Anyhow, as you suggested in the thread, it’d be a good idea to add a
> ‘tunable?’ property.
Will simply adding (tunable? . #t) as a property be enough?  Also
related to the signeli thing, do we have the means to create special
build flows for tuned packages?

Cheers
Ludovic Courtès Nov. 7, 2022, 1:35 p.m. UTC | #3
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> Am Sonntag, dem 06.11.2022 um 18:39 +0100 schrieb Ludovic Courtès:
>> Hi Liliana,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
>> 
>> > * gnu/packages/bqn.scm (cbqn)[inputs]: Remove singeli-sources.
>> > [arguments]<#:make-flags: Replace “o3n-singeli” with “o3”.
>> > <#:phases>: Remove “link-singeli”.
>> 
>> This series of patches that you sent LGTM!
>> 
>> However, how does it relate to AVX2-specific builds?  
> IIUC, singeli is some tool that emits avx2-specific opcodes and the
> singeli builds of cbqn use that somehw; I admit, I do not completely
> understand what's going on on their side.

Oh, I see.

>> Anyhow, as you suggested in the thread, it’d be a good idea to add a
>> ‘tunable?’ property.
> Will simply adding (tunable? . #t) as a property be enough?  Also
> related to the signeli thing, do we have the means to create special
> build flows for tuned packages?

Yes, ci.guix builds tunable packages for several x86_64 ISA variants,
which are listed in (gnu ci).

Thanks,
Ludo’.
Liliana Marie Prikler Nov. 7, 2022, 9:03 p.m. UTC | #4
Am Montag, dem 07.11.2022 um 14:35 +0100 schrieb Ludovic Courtès:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > Am Sonntag, dem 06.11.2022 um 18:39 +0100 schrieb Ludovic Courtès:
> > > Hi Liliana,
> > > 
> > > Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> > > 
> > > > * gnu/packages/bqn.scm (cbqn)[inputs]: Remove singeli-sources.
> > > > [arguments]<#:make-flags: Replace “o3n-singeli” with “o3”.
> > > > <#:phases>: Remove “link-singeli”.
> > > 
> > > This series of patches that you sent LGTM!
> > > 
> > > However, how does it relate to AVX2-specific builds?  
> > IIUC, singeli is some tool that emits avx2-specific opcodes and the
> > singeli builds of cbqn use that somehw; I admit, I do not
> > completely understand what's going on on their side.
> 
> Oh, I see.
> 
> > > Anyhow, as you suggested in the thread, it’d be a good idea to
> > > add a ‘tunable?’ property.
> > Will simply adding (tunable? . #t) as a property be enough?  Also
> > related to the signeli thing, do we have the means to create
> > special build flows for tuned packages?
> 
> Yes, ci.guix builds tunable packages for several x86_64 ISA variants,
> which are listed in (gnu ci).
Done and pushed.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index c4e0f39efb..02f539bb8b 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -182,12 +182,9 @@  (define-public cbqn
     (name "cbqn")
     (outputs '("out" "lib"))
     (arguments
-     (list #:make-flags '(list "shared-o3" "o3n-singeli")
+     (list #:make-flags '(list "shared-o3" "o3")
            #:phases #~(modify-phases %standard-phases
                         (delete 'configure)
-                        (add-before 'build 'link-singeli
-                          (lambda* (#:key inputs #:allow-other-keys)
-                            (symlink #+singeli-sources "Singeli")))
                         (add-before 'build 'generate-bytecode
                           (lambda* (#:key inputs #:allow-other-keys)
                             (system (string-append #+dbqn
@@ -218,7 +215,6 @@  (define-public cbqn
                               (install-file "libcbqn.so" lib)))))))
     (native-inputs (list dbqn
                          bqn-sources
-                         singeli-sources
                          libffi
                          clang-toolchain
                          linux-libre-headers))))