diff mbox series

[bug#59003,4/7] installer: Use 'current-guix' for extensions.

Message ID 20221103191935.16336-4-ludo@gnu.org
State New
Headers show
Series Warn about unsupported devices | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Ludovic Courtès Nov. 3, 2022, 7:19 p.m. UTC
This lets us use the latest (gnu build linux-modules) for instance.
Note that items listed in 'with-extensions' come first in the load path,
before the directory containing the modules in 'with-imported-modules'.

* gnu/installer.scm (installer-program): Use (current-guix) instead of
'guix' in 'with-extensions'.
---
 gnu/installer.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

pelzflorian (Florian Pelz) Nov. 5, 2022, 9:09 a.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> writes:
> -                           guix gnutls)
> +                           (current-guix) gnutls)

This change is bad, it seems.

Having applied the patch on a local checkout on a machine which is not
in the .guix-authorizations file,

* when I run
./pre-inst-env guix system image -t iso9660 gnu/system/install.scm
breaks build for me because the commit is not authorized.  This is a bad
regression.

* when I `guix pull` with the guix channel pointing to the local
checkout,
guix system image -t iso9660 gnu/system/install.scm
produces an installer image with the old installer from the guix
package.

I haven’t fully understood (current-guix), but it seems better to update
the guix package, maybe.

Regards,
Florian
Ludovic Courtès Nov. 5, 2022, 5:34 p.m. UTC | #2
Hi Florian,

"pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>> -                           guix gnutls)
>> +                           (current-guix) gnutls)
>
> This change is bad, it seems.

Yes, it’s not great.  We could skip it provided we first upgrade the
‘guix’ package (with “make update-guix-package”) so that we get the
latest (gnu build linux-modules) module.  You can do that to test things
locally.

We’re doing:

  (with-extension (list … guix …)
    (with-imported-modules (list … guix modules …)
      …))

and it turns out that extensions take precedence in %load-path.  So
merely adding (gnu build linux-modules) to the ‘with-imported-modules’
list isn’t enough, unfortunately.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/installer.scm b/gnu/installer.scm
index 5cd1af8edf..df7625e05c 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -358,7 +358,7 @@  (define installer-builder
     (with-extensions (list guile-gcrypt guile-newt
                            guile-parted guile-bytestructures
                            guile-json-3 guile-git guile-webutils
-                           guix gnutls)
+                           (current-guix) gnutls)
       (with-imported-modules `(,@(source-module-closure
                                   `(,@modules
                                     (gnu services herd)