diff mbox series

[bug#58811] gnu: Add uxn.

Message ID 20221027020819.5915-1-antero@mailbox.org
State New
Headers show
Series [bug#58811] gnu: Add uxn. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Antero Mejr Oct. 27, 2022, 2:08 a.m. UTC
* gnu/packages/emulators.scm (uxn): New variable.
---
 gnu/packages/emulators.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

宋文武 Nov. 1, 2022, 6:47 a.m. UTC | #1
Antero Mejr <antero@mailbox.org> writes:

Hello,
> * gnu/packages/emulators.scm (uxn): New variable.
> [...]
> +                            (lambda _
> +                              (let ((bin (string-append #$output "/bin")))
> +                                (copy-recursively "bin" bin)))))))
After built, under /bin, there are:
  piano.rom
  piano.log
  uxncli
  launcher.rom
  asma.rom
  uxnasm
  uxnemu

Only uxncli, uxnasm and uxnemu should go into /bin, the rom files can go
into /share/uxn, the piano.log file should be removed.

Can you send an update patch?  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 08719c336e..79977acff6 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -2494,3 +2494,39 @@  (define-public cc65
     (description "This package provides a development environment for 6502 systems, including macro assembler, C compiler, linker, librarian and several other tools.")
     (home-page "https://cc65.github.io/")
     (license license:zlib)))
+
+(define-public uxn
+  (let ((commit "1b2049e238df96f32335edf1c6db35bd09f8b42d")
+        (revision "1"))
+    (package
+      (name "uxn")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~rabbits/uxn")
+                      (commit commit)))
+                (file-name (string-append name "-" version))
+                (sha256
+                 (base32
+                  "0d3hy1db1mfk2l7q7wdxvp1z0vkmyyb9pdp81d9zm58ylpxaq2cp"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:tests? #f ;no tests
+             #:phases #~(modify-phases %standard-phases
+                          (delete 'configure)
+                          (replace 'build
+                            (lambda _
+                              (setenv "CC" #$(cc-for-target))
+                              (invoke "./build.sh" "--norun")))
+                          (replace 'install
+                            (lambda _
+                              (let ((bin (string-append #$output "/bin")))
+                                (copy-recursively "bin" bin)))))))
+      (inputs (list sdl2))
+      (home-page "https://100r.co/site/uxn.html")
+      (synopsis "Assembler and emulator for the Uxn stack-machine")
+      (description
+       "This package provides an assembler and emulator for the Uxn
+stack-machine, written in ANSI C.  Graphical output is implemented using SDL2.")
+      (license license:expat))))