diff mbox series

[bug#56167] gnu: Add r-awst.

Message ID 20220623124454.28787-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56167] gnu: Add r-awst. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 23, 2022, 12:44 p.m. UTC
* gnu/packages/bioconductor.scm (r-awst): New variable.
---
 gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9

Comments

Ricardo Wurmus Oct. 31, 2022, 8:37 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..fa9c728a44 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,32 @@  (define-public r-aneufinder
 sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-awst
+  (package
+    (name "r-awst")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "awst" version))
+              (sha256
+               (base32
+                "0iw3zycmj95rmdx7f2w0j4yxkzd90y87lrzgdn9cyvvzi5avflav"))))
+    (properties `((upstream-name . "awst")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/drisso/awst")
+    (synopsis "Asymmetric within-sample transformation")
+    (description
+     "This package @dfn{awst} (Asymmetric Within-Sample Transformation) that
+regularizes RNA-seq read counts and reduces the effect of noise on the
+classification of samples.  @code{AWST} comprises two main steps: standardization
+and smoothing.  These steps transform gene expression data to reduce the noise
+of the lowly expressed features, which suffer from background effects and low
+signal-to-noise ratio, and the influence of the highly expressed features, which
+may be the result of amplification bias and other experimental artifacts.")
+    (license license:expat)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")