diff mbox series

[bug#57862,PATCHES] Add package ghc-hxt-xpath

Message ID 20220916155835.4b1ae4cc@ens-lyon.fr
State Accepted
Headers show
Series [bug#57862,PATCHES] Add package ghc-hxt-xpath | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Alice BRENON Sept. 16, 2022, 1:58 p.m. UTC
Hi guix,

I use the little time required to fix the display between two talks of
the 10 years anniversary to submit this proposal for a new haskell
package. It's an extension of the HXT library for XML made to handle
XPaths.

Happy birthday Guix !!

Alice

Comments

Christopher Baines Oct. 8, 2022, 11:07 a.m. UTC | #1
Alice BRENON <alice.brenon@ens-lyon.fr> writes:

> I use the little time required to fix the display between two talks of
> the 10 years anniversary to submit this proposal for a new haskell
> package. It's an extension of the HXT library for XML made to handle
> XPaths.

Thanks Alice, I've pushed this to master as
14afaa5381b1185bf9e3701ff09c5bab12dacfab.

Chris
diff mbox series

Patch

From 9efbd82e9c566a6523dc54356dd4981fe6fac789 Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Tue, 13 Sep 2022 17:35:20 +0200
Subject: [PATCH] gnu: Add ghc-hxt-xpath.

* gnu/packages/haskell-web.scm (ghc-hxt-xpath): New variable.
---
 gnu/packages/haskell-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 1c2538b45e..0e82d65e27 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2020, 2022 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 Alice Brenon <alice.brenon@ens-lyon.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1541,6 +1542,26 @@  (define-public ghc-hxt
 introduces a more general approach for processing XML with Haskell.")
     (license license:expat)))
 
+(define-public ghc-hxt-xpath
+  (package
+    (name "ghc-hxt-xpath")
+    (version "9.1.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "hxt-xpath" version))
+              (sha256
+               (base32
+                "0wlq9s01icalnvjkkilx5zaqp3ff4v5limj1xy8i18qpzjspqdsh"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-hxt))
+    (home-page "https://github.com/UweSchmidt/hxt")
+    (synopsis "The XPath modules for HXT.")
+    (description
+     "This extension for the Haskell XML Toolbox defines data types to
+represent XPath, navigation trees and primitives to select and edit subtrees
+from them.  Some primitives have both a functional and an arrow interface.")
+    (license license:expat)))
+
 (define-public ghc-http-common
   (package
     (name "ghc-http-common")
-- 
2.37.2