diff mbox series

[bug#57860] gnu: libdaemon: fix the cross build.

Message ID CAGNyvejKfwzUwvc9Ocq3bE6ZAsOMRhD+=mNTwMS8=bECQEaoMw@mail.gmail.com
State Accepted
Headers show
Series [bug#57860] gnu: libdaemon: fix the cross build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

路辉 Sept. 16, 2022, 1:21 p.m. UTC

Comments

Christopher Baines Oct. 6, 2022, 2:19 p.m. UTC | #1
路辉 <luhux76@gmail.com> writes:

> [2. text/x-patch; 0001-gnu-libdaemon-fix-the-cross-build.patch]...

Thanks for the patch. I tweaked the commit message slightly to try and
make it more specific, and pushed to master as
5b42b64ea89564c58325d16d3d0f4a0a03ebae0f.

Chris
diff mbox series

Patch

From bec033b9045a375530f23020eaa96819376d9417 Mon Sep 17 00:00:00 2001
From: Lu Hui <luhux76@gmail.com>
Date: Fri, 16 Sep 2022 20:46:06 +0800
Subject: [PATCH] gnu: libdaemon: fix the cross build.

* gnu/packages/libdaemon.scm (libdaemon): fix cross build
---
 gnu/packages/libdaemon.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/libdaemon.scm b/gnu/packages/libdaemon.scm
index 9dc851e823..12e4e2dc9c 100644
--- a/gnu/packages/libdaemon.scm
+++ b/gnu/packages/libdaemon.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 LuHui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -49,7 +50,8 @@  (define-public libdaemon
              (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (native-inputs
-     (if (and=> (%current-target-system) target-aarch64?)
+     (if (or (and=> (%current-target-system) target-aarch64?)
+             (and=> (%current-target-system) target-riscv64?))
          `(("config" ,config)) ; for config.sub
          '()))
     (arguments
@@ -66,7 +68,8 @@  (define-public libdaemon
                                        ;; Hurd's console client.
                                        "--localstatedir=/var"))
              '())
-       ,@(if (and=> (%current-target-system) target-aarch64?)
+       ,@(if (or (and=> (%current-target-system) target-aarch64?)
+                 (and=> (%current-target-system) target-riscv64?))
              `(#:phases
                (modify-phases %standard-phases
                  (add-before 'configure 'update-config.sub
-- 
2.37.3