diff mbox series

[bug#57824,2/2] gnu: Add r-gldex.

Message ID 20220915084505.31265-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57824,1/2] gnu: Add r-spacefillr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 15, 2022, 8:45 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-gldex): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Christopher Baines Oct. 6, 2022, 2:17 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-gldex): New variable.
> ---
>  gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)

Thanks, pushed to master as 5b42b64ea89564c58325d16d3d0f4a0a03ebae0f.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 785df056c6..f806191cf5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21167,6 +21167,33 @@  (define-public r-glasso
 path of values for the regularization parameter.")
     (license license:gpl2)))
 
+(define-public r-gldex
+  (package
+    (name "r-gldex")
+    (version "2.0.0.9")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "GLDEX" version))
+              (sha256
+               (base32
+                "1g0wg6z4ba1n6p2nw3kr734wlgmq0aw1a4spr6xw6djj7idsfi61"))))
+    (properties `((upstream-name . "GLDEX")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-cluster r-spacefillr))
+    (home-page "https://cran.r-project.org/package=GLDEX")
+    (synopsis "Fitting single and mixture of generalised lambda distributions")
+    (description
+     "@code{GLDEX} offers fitting algorithms corresponding to two major
+objectives.  One is to provide a smoothing device to fit distributions to data
+using the weighted and unweighted discretised approach based on the bin width
+of the histogram.  The other is to provide a definitive fit to the data set
+using the maximum likelihood and quantile matching estimation.  Other methods
+such as moment matching, starship method, and L moment matching are also
+provided.  Diagnostics on goodness of fit can be done via qqplots, KS-resample
+tests and comparing mean, variance, skewness and kurtosis of the data with the
+fitted distribution.")
+    (license license:gpl3+)))
+
 (define-public r-rhpcblasctl
   (package
     (name "r-rhpcblasctl")