diff mbox series

[bug#58155] etc: teams: Add news.scm to translations team scope.

Message ID 20220929032058.34400-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#58155] etc: teams: Add news.scm to translations team scope. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Sept. 29, 2022, 3:20 a.m. UTC
* etc/teams.scm.in (translations)[#:scope]: Add etc/news.scm.
---

Hello,

I'm interested in receiving emails about changes in etc/news.scm.
This patch assumes other members of the translations team are as well.

 etc/teams.scm.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Sept. 29, 2022, 7:20 a.m. UTC | #1
Am Donnerstag, dem 29.09.2022 um 00:20 -0300 schrieb Thiago Jung
Bauermann:
> * etc/teams.scm.in (translations)[#:scope]: Add etc/news.scm.
> ---
> 
> Hello,
> 
> I'm interested in receiving emails about changes in etc/news.scm.
> This patch assumes other members of the translations team are as
> well.
Since changes to NEWS and po rarely go through the mailing lists, I
doubt this will have the intended effect.  (Of course we can still add
the scope, it most likely will do exactly nothing, i.e. neither good
nor harm.)  Is there anything else we can do to improve the translation
workflow?
Thiago Jung Bauermann Oct. 1, 2022, 11:19 p.m. UTC | #2
Hello Liliana,

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

> Am Donnerstag, dem 29.09.2022 um 00:20 -0300 schrieb Thiago Jung
> Bauermann:
>> * etc/teams.scm.in (translations)[#:scope]: Add etc/news.scm.
>> ---
>> 
>> Hello,
>> 
>> I'm interested in receiving emails about changes in etc/news.scm.
>> This patch assumes other members of the translations team are as
>> well.
> Since changes to NEWS and po rarely go through the mailing lists, I
> doubt this will have the intended effect.  (Of course we can still add
> the scope, it most likely will do exactly nothing, i.e. neither good
> nor harm.)

This patch doesn't add scope entries for NEWS nor for po files though.
There's a scope entry for the latter but it was added by a previous
patch.

I thought that changes to etc/news.scm went through the mailing lists
but it looks like they don't so this patch is less useful than I
thought...

I still think it would be useful to apply it, as a kind of
documentation/statement that the translations team is interested in
changes to etc/news.scm.

Relatedly, it would be a good idea for people adding new entries to
etc/news.scm to notify members of the translations team.

> Is there anything else we can do to improve the translation
> workflow?

I think Julien Lepiller's proposal to translate news on weblate would be
a nice improvement:

https://yhetil.org/guix/20220721222734.0f0ac881@sybil.lepiller.eu/
Mathieu Othacehe Oct. 3, 2022, 1:32 p.m. UTC | #3
Hey,

> Relatedly, it would be a good idea for people adding new entries to
> etc/news.scm to notify members of the translations team.

We could state that modifications to etc/news.scm should go to review
and with you change, the members of the translation team would be
notified.

Applied, thanks!

Mathieu
diff mbox series

Patch

diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 2727505529c6..c27ea5271e54 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -354,7 +354,8 @@  (define-team games
 (define-team translations
   (team 'translations
         #:name "Translations"
-        #:scope (list (make-regexp "^po/"))))
+        #:scope (list "etc/news.scm"
+                      (make-regexp "^po/"))))
 
 (define-team installer
   (team 'installer