diff mbox series

[bug#58037] gnu: picard: Update to 2.8.3, modernize package.

Message ID 79238a8ccadaf28f35de0e78c8a7649967d0ef12.1663997932.git.kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#58037] gnu: picard: Update to 2.8.3, modernize package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Sept. 24, 2022, 5:39 a.m. UTC
* gnu/packages/music.scm (picard): Update to 2.8.3.
[source]: Remove patch.
[arguments]: Use G-expressions. Remove trailing #t.
[native-inputs]: Remove input labels.
[inputs]: Add python-fasteners, python-pyyaml, python-markdown, python-pyjwt. Remove a transitive
dependency on QtWebKit. See <https://issues.guix.gnu.org/53289> for more information about this change.
* gnu/packages/patches/picard-fix-id3-rename-test.patch: Remove it.
* gnu/local.mk (dist_path_DATA): Update accordingly.
---
 gnu/local.mk                                  |  1 -
 gnu/packages/music.scm                        | 47 ++++++++++---------
 .../patches/picard-fix-id3-rename-test.patch  | 11 -----
 3 files changed, 26 insertions(+), 33 deletions(-)
 delete mode 100644 gnu/packages/patches/picard-fix-id3-rename-test.patch


base-commit: cbe8391d7c570a12416acfbfbbb818404d8b9203

Comments

Mathieu Othacehe Sept. 30, 2022, 1:46 p.m. UTC | #1
> * gnu/packages/music.scm (picard): Update to 2.8.3.
> [source]: Remove patch.
> [arguments]: Use G-expressions. Remove trailing #t.
> [native-inputs]: Remove input labels.
> [inputs]: Add python-fasteners, python-pyyaml, python-markdown, python-pyjwt. Remove a transitive
> dependency on QtWebKit. See <https://issues.guix.gnu.org/53289> for more information about this change.
> * gnu/packages/patches/picard-fix-id3-rename-test.patch: Remove it.
> * gnu/local.mk (dist_path_DATA): Update accordingly.

Applied, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index ef1bae5f3c..74de2f7517 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1648,7 +1648,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/phoronix-test-suite-fsdg.patch		\
   %D%/packages/patches/php-bug-74093-test.patch			\
   %D%/packages/patches/php-curl-compat.patch			\
-  %D%/packages/patches/picard-fix-id3-rename-test.patch		\
   %D%/packages/patches/picprog-non-intel-support.patch		\
   %D%/packages/patches/pidgin-add-search-path.patch		\
   %D%/packages/patches/pinball-system-ltdl.patch		\
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 66b4beae0c..db0522609c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3524,7 +3524,7 @@  (define-public pianobar
 (define-public picard
   (package
     (name "picard")
-    (version "2.4.4")
+    (version "2.8.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -3532,30 +3532,35 @@  (define-public picard
                     "picard/picard-" version ".tar.gz"))
               (sha256
                (base32
-                "1c5l7i43jaj3s4wklc0cba6nn2x9cmpcggk4q4h9m1bci2xilsiy"))
-              (patches (search-patches "picard-fix-id3-rename-test.patch"))))
+                "0h4yk1y4k23hkfk7k2in27rd34ani857m0vvn7xa8vxizz951dka"))))
     (build-system python-build-system)
     (arguments
-     '(#:use-setuptools? #f
-       #:configure-flags
-       (list "--root=/"
-             ;; Don't phone home or show ‘Check for Update…’ in the Help menu.
-             "--disable-autoupdate")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "picard/const/__init__.py"
-               (("pyfpcalc")
-                (string-append
-                 "pyfpcalc', '"
-                 (assoc-ref inputs "chromaprint") "/bin/fpcalc")))
-             #t)))))
+     (list
+      #:use-setuptools? #f
+      #:configure-flags
+      #~(list "--root=/"
+              ;; Don't phone home or show ‘Check for Update…’ in the Help menu.
+              "--disable-autoupdate")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-source
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "picard/const/__init__.py"
+                (("pyfpcalc")
+                 (string-append
+                  "pyfpcalc', '"
+                  (assoc-ref inputs "chromaprint") "/bin/fpcalc"))))))))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("python-dateutil" ,python-dateutil)))
+     (list gettext-minimal python-dateutil))
     (inputs
-     (list chromaprint python-discid python-pyqt python-mutagen))
+     (list chromaprint
+           python-discid
+           python-pyqt-without-qtwebkit
+           python-mutagen
+           python-fasteners
+           python-pyyaml
+           python-markdown
+           python-pyjwt))
     (home-page "https://picard.musicbrainz.org/")
     (synopsis "Graphical music tagging application")
     (description
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
deleted file mode 100644
index 3c4fa63c84..0000000000
--- a/gnu/packages/patches/picard-fix-id3-rename-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@ 
-Index: b/test/formats/test_id3.py
-===================================================================
---- a/test/formats/test_id3.py
-+++ b/test/formats/test_id3.py
-@@ -266,5 +266,5 @@
-         def test_rename_txxx_tags(self):
-             file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
--            filename = self.copy_file_tmp(file_path, 'mp3')
-+            filename = self.copy_file_tmp(file_path, '.mp3')
-             raw_metadata = load_raw(filename)
-             self.assertIn('TXXX:Artists', raw_metadata)