diff mbox series

[bug#57991] gnu: Add gnome-shell-extension-unite-shell

Message ID 297f3b6561597ae3ce161e37a748a73c7cdd9474.1663806080.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57991] gnu: Add gnome-shell-extension-unite-shell | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 22, 2022, 12:20 a.m. UTC
---
 gnu/packages/gnome-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++-
 1 file changed, 40 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Sept. 28, 2022, 9:22 p.m. UTC | #1
Hi,

Trevor Richards <trev@trevdev.ca> skribis:

> ---
>  gnu/packages/gnome-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++-
>  1 file changed, 40 insertions(+), 1 deletion(-)

I augmented the commit log and applied it.

> +    (home-page "https://github.com/hardpixel/unite-shell")
> +    (synopsis "Top panel and window decoration extension for GNOME Shell")
> +    (description
> +     "Unite is a GNOME Shell extension which makes a few layout
> +tweaks to the top panel and removes window decorations to make it look like
> +Ubuntu Unity Shell.")
> +    (license license:gpl3)))

I wondered whether that really was GPLv3-only, and ‘README.md’ suggests
it is.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4d53593944..7ec693851c 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -69,7 +69,8 @@  (define-module (gnu packages gnome-xyz)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages web)
-  #:use-module (gnu packages xml))
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages xorg))
 
 (define-public arc-icon-theme
   (package
@@ -303,6 +304,44 @@  (define-public gnome-plots
 takes advantage of modern hardware using OpenGL.")
     (license license:gpl3+)))
 
+(define-public gnome-shell-extension-unite-shell
+  (package
+    (name "gnome-shell-extension-unite-shell")
+    (version "65")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hardpixel/unite-shell")
+                    (commit "127edac6396b89cdedec003bdff38820e6a0f91f")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lzhf7hlvzg62nxjfpv265315qibcjz5dv08dzpfckf2dx68nab4"))))
+    (build-system copy-build-system)
+    (native-inputs (list `(,glib "bin") gettext-minimal))
+    (inputs (list xprop))
+    (arguments
+     (list #:install-plan ''(("./unite@hardpixel.eu"
+                              "share/gnome-shell/extensions/unite@hardpixel.eu"))
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'patch-xprop-bin
+                          (lambda _
+                            (substitute* "unite@hardpixel.eu/window.js"
+                              (("xprop")
+                               (string-append #$(this-package-input "xprop")
+                                              "/bin/xprop")))))
+                        (add-before 'install 'compile-schemas
+                          (lambda _
+                            (with-directory-excursion "unite@hardpixel.eu/schemas"
+                              (invoke "glib-compile-schemas" ".")))))))
+    (home-page "https://github.com/hardpixel/unite-shell")
+    (synopsis "Top panel and window decoration extension for GNOME Shell")
+    (description
+     "Unite is a GNOME Shell extension which makes a few layout
+tweaks to the top panel and removes window decorations to make it look like
+Ubuntu Unity Shell.")
+    (license license:gpl3)))
+
 (define-public gnome-shell-extension-appindicator
   (package
     (name "gnome-shell-extension-appindicator")