diff mbox series

[bug#58143,2/2] gnu: bloomberg-bde: Update to 3.108.0.1.

Message ID da37d8c6edbaed1001352e355a8b4d69f88b74e0.1664219254.git.code@greghogan.com
State New
Headers show
Series Update bloomberg-bde. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 28, 2022, 1:14 p.m. UTC
* gnu/packages/cpp.scm (bloomberg-bde): Update to 3.108.0.1.
[source](origin): Update test deletion list.
---
 gnu/packages/cpp.scm | 20 ++++++++------------
 1 file changed, 8 insertions(+), 12 deletions(-)

Comments

Maxim Cournoyer Sept. 28, 2022, 7:10 p.m. UTC | #1
Hello,

Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/cpp.scm (bloomberg-bde): Update to 3.108.0.1.
> [source](origin): Update test deletion list.
> ---
>  gnu/packages/cpp.scm | 20 ++++++++------------
>  1 file changed, 8 insertions(+), 12 deletions(-)

Oof, this took a long time to build, and eventually failed with one
test:

--8<---------------cut here---------------start------------->8---
s_baltst_testtaggedvalueutil                        =   0.05 sec*proc (1 test)
s_baltst_testtaggedvalueutil.t                      =   0.05 sec*proc (1 test)

Total Test time (real) = 922.80 sec

The following tests FAILED:
        806 - bsls_timeutil.t (Failed)
Errors while running CTest
make: *** [Makefile:93: test] Error 8

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("test") exit-status: 2 term-signal: #f stop-signal: #f> 
phase `check' failed after 923.9 seconds
command "make" "test" failed with status 2
builder for `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed with exit code 1
@ build-failed /gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv - 1 builder for `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed with exit code 1
derivation '/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' offloaded to 'localhost' failed: build of `/gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv' failed
build of /gnu/store/y608pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv failed
View build log at
'/var/log/guix/drvs/y6/08pbn2www99sxhvpa85jqkffh55jm6-bloomberg-bde-3.108.0.1.drv'.
--8<---------------cut here---------------end--------------->8---

Could you please report it upstream (if not already) and disable it?

Thank you,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index aa986557a8..4cde47e1f2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1782,11 +1782,11 @@  (define-public bloomberg-bde-tools
       (license license:asl2.0))))
 
 (define-public bloomberg-bde
-  (let ((commit "b6bcc0e24a5862bf77aea7edd831dedf50e21d64"))
+  (let ((commit "86f9391332c87b896817a3b5a8f1c3ff113178b6"))
     (package
       (name "bloomberg-bde")
       ;; Recent releases are not tagged so commit must be used for checkout.
-      (version "3.98.0.0")
+      (version "3.108.0.1")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -1795,7 +1795,7 @@  (define-public bloomberg-bde
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0y3lipi1lj9qazgc935851r2qsx5aq3vvc4y52jq57riyz8wg3ma"))
+                  "024psi9kv9069fga3y5y37b322871jpnm7xgdg1gl8s929y8czyl"))
                 (patches
                  (search-patches
                   "bloomberg-bde-cmake-module-path.patch"))
@@ -1809,18 +1809,14 @@  (define-public bloomberg-bde
                     ;; Delete failing tests.
                     (for-each
                      delete-file
-                     (list "groups/bal/ball/ball_asyncfileobserver.t.cpp"
-                           "groups/bal/ball/ball_fileobserver2.t.cpp"
+                     (list "groups/bal/ball/ball_fileobserver2.t.cpp"
                            "groups/bal/ball/ball_recordstringformatter.t.cpp"
                            "groups/bal/balst/balst_stacktraceutil.t.cpp"
-                           "groups/bdl/bdlmt/bdlmt_eventscheduler.t.cpp"
-                           "groups/bdl/bdlmt/bdlmt_timereventscheduler.t.cpp"
                            "groups/bdl/bdls/bdls_filesystemutil.t.cpp"
-                           "groups/bsl/bslh/bslh_hashpair.t.cpp"
-                           "groups/bsl/bsls/bsls_platform.t.cpp"
-                           "groups/bsl/bsls/bsls_stackaddressutil.t.cpp"
-                           "groups/bsl/bsls/bsls_stopwatch.t.cpp"
-                           "groups/bsl/bslstl/bslstl_function_invokerutil.t.cpp"))
+                           "groups/bsl/bslh/bslh_hash.t.cpp"
+                           "groups/bsl/bslstl/bslstl_deque.1.t.cpp"
+                           "groups/bsl/bslstl/bslstl_deque.2.t.cpp"
+                           "groups/bsl/bslstl/bslstl_deque.3.t.cpp"))
                     #t))))
       (build-system cmake-build-system)
       (arguments