From 14b58121576e154b4bf96564dffb9fd09f5e0b81 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 17 Sep 2022 00:23:33 +0300
Subject: [PATCH] gnu: Add maven-sisu-plugin.
* gnu/packages/maven.scm (maven-sisu-plugin): New variable.
---
gnu/packages/maven.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
@@ -27,6 +27,7 @@ (define-module (gnu packages maven)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system ant)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
@@ -3012,6 +3013,50 @@ (define-public maven-enforcer-plugin
maven-plugin-annotations
maven-enforcer-parent-pom))))
+(define-public maven-sisu-plugin
+ (package
+ (name "maven-sisu-plugin")
+ (version "0.3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/sisu.mojos/")
+ (commit (string-append "releases/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00hb7v6hz8jg0mgkj3cl0nmqz49za4k2a0rbjr4gdhy2m7f34sq3"))))
+ (build-system ant-build-system)
+ (arguments
+ (list #:jar-name "maven-sisu-plugin.jar"
+ #:source-dir "src"
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'generate-plugin.xml
+ (generate-plugin.xml "pom.xml" "sisu"
+ "src/main/java/org/eclipse/sisu/mojos/"
+ (list (list "IndexMojo.java")
+ (list "MainIndexMojo.java")
+ (list "TestIndexMojo.java"))))
+ (replace 'install
+ (install-from-pom "pom.xml")))))
+ (propagated-inputs (list java-sonatype-oss-parent-pom-9))
+ (inputs (list maven-artifact
+ maven-plugin-api
+ maven-plugin-annotations
+ maven-core
+ maven-common-artifact-filters
+ java-slf4j-nop
+ java-eclipse-sisu-inject
+ java-plexus-utils
+ java-plexus-build-api
+ java-slf4j-api))
+ (home-page "https://www.eclipse.org/sisu/")
+ (synopsis "Maven plugin that generates annotation indexes for Sisu")
+ (description "Maven plugin that generates annotation indexes for Sisu to
+avoid classpath scanning at runtime.")
+ (license license:epl1.0)))
+
(define-public maven-artifact-transfer
(package
(name "maven-artifact-transfer")
--
2.34.1