diff mbox series

[bug#57545] gnu: python-pip: Update to 22.2.2.

Message ID 836b014265b8d5f48a78226a2bcc7d0d1cb48a15.1662134828.git.code@greghogan.com
State Accepted
Headers show
Series [bug#57545] gnu: python-pip: Update to 22.2.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 2, 2022, 4:41 p.m. UTC
The pip README notes that "pip 21.0, in January 2021, removed Python 2
support". If continued Python 2 support for python-pip is desired, the
old version could be preserved until such time as python2 is removed.

* gnu/packages/python-xyz.scm (python-pip): Update to 22.2.2.
---
 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Christopher Baines Sept. 10, 2022, 10:51 a.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> The pip README notes that "pip 21.0, in January 2021, removed Python 2
> support". If continued Python 2 support for python-pip is desired, the
> old version could be preserved until such time as python2 is removed.
>
> * gnu/packages/python-xyz.scm (python-pip): Update to 22.2.2.
> ---
>  gnu/packages/python-xyz.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Thanks Greg, I've pushed this to master as
fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b058704172..7b658daaf6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12457,14 +12457,14 @@  (define-public python-pretend
 (define-public python-pip
   (package
     (name "python-pip")
-    (version "20.2.4")
+    (version "22.2.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pip" version))
        (sha256
         (base32
-         "18b4qcijwivvkj1g0hs4w8zjbks0bjzdjcrqybnhmyx0gs2rmjc5"))))
+         "0jwac0bhfp48w4fqibf1ysrs2grksdv92hwqm7bmdw2jn2fr5l9z"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f))          ; there are no tests in the pypi archive.