diff mbox series

[bug#57162] gnu: pipe-viewer: Update to 0.2.3

Message ID 20220812210126.1082170-1-mail@ykonai.net
State Accepted
Headers show
Series [bug#57162] gnu: pipe-viewer: Update to 0.2.3 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

ykonai Aug. 12, 2022, 9:01 p.m. UTC
* gnu/packages/video.scm (pipe-viewer): Update to 0.2.3
* gnu/packages/video.scm (pipe-viewer): Remove unnecessary dependency on
youtube-dl

Currently, this program is broken due to an API change with Youtube. This
update should fix it. Youtube-dl should be unnecessary since 0.2.1.
---
 gnu/packages/video.scm | 11 ++---------
 1 file changed, 2 insertions(+), 9 deletions(-)


base-commit: ecc2587f1f2c4bd693f1f08a9f681a3d829d0289

Comments

Ludovic Courtès Aug. 31, 2022, 9:38 p.m. UTC | #1
Hi,

ykonai <mail@ykonai.net> skribis:

> * gnu/packages/video.scm (pipe-viewer): Update to 0.2.3
> * gnu/packages/video.scm (pipe-viewer): Remove unnecessary dependency on
> youtube-dl
>
> Currently, this program is broken due to an API change with Youtube. This
> update should fix it. Youtube-dl should be unnecessary since 0.2.1.

Applied, thanks!  (Though FWIW pipe-viewer 0.2.0 is still working for me.)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6d0b5ccb58..f575dd0cfe 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1090,7 +1090,7 @@  (define-public mkvtoolnix
 (define-public pipe-viewer
   (package
     (name "pipe-viewer")
-    (version "0.2.0")
+    (version "0.2.3")
     (source
      (origin
        (method git-fetch)
@@ -1100,7 +1100,7 @@  (define-public pipe-viewer
          (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "19qfs0nv7l01468f14a5zbvaiff5hrsk3a4zqknh15014xnvw08s"))))
+        (base32 "0c2v4pj86442sp71ndjmvd2bl1grp6g9ya2ywdaihq1f2djk6jxl"))))
     (build-system perl-build-system)
     (arguments
      `(#:imported-modules
@@ -1120,9 +1120,6 @@  (define-public pipe-viewer
          (add-after 'unpack 'patch-source
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* (find-files "lib" "\\.pm$")
-               (("\"youtube-dl\"")
-                (format #f "\"~a/bin/youtube-dl\""
-                        (assoc-ref inputs "youtube-dl")))
                (("\"yt-dlp\"")
                 (format #f "\"~a/bin/yt-dlp\""
                         (assoc-ref inputs "yt-dlp"))))
@@ -1136,9 +1133,6 @@  (define-public pipe-viewer
                (("'xdg-open'")
                 (format #f "'~a/bin/xdg-open'"
                         (assoc-ref inputs "xdg-utils")))
-               (("'youtube-dl'")
-                (format #f "'~a/bin/youtube-dl'"
-                        (assoc-ref inputs "youtube-dl")))
                (("'yt-dlp'")
                 (format #f "'~a/bin/yt-dlp'"
                         (assoc-ref inputs "yt-dlp"))))))
@@ -1192,7 +1186,6 @@  (define-public pipe-viewer
            perl-uri-escape
            wget
            xdg-utils
-           youtube-dl
            yt-dlp))
     (propagated-inputs
      (list dconf))