diff mbox series

[bug#57492,core-updates] gnu: boost: Update to 1.80.0.

Message ID 6e6c289860d63d17dbcf7295c912e20fe2df164b.1661877251.git.code@greghogan.com
State Accepted
Headers show
Series [bug#57492,core-updates] gnu: boost: Update to 1.80.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Aug. 30, 2022, 4:36 p.m. UTC
* gnu/packages/boost.scm (boost): Update to 1.80.0.
[source](patches): Add new and remove old upstream patches.
---
 gnu/packages/boost.scm | 26 ++++++++++++++++++++------
 1 file changed, 20 insertions(+), 6 deletions(-)

Comments

M Aug. 30, 2022, 7:50 p.m. UTC | #1
On 30-08-2022 18:36, Greg Hogan wrote:

> +                      ;; Boost.Filesystem directory iterators may fail to
> +                      ;; construct for a network share on Windows prior to 10:
> +                      ;;https://github.com/boostorg/filesystem/pull/246,
> +                      ;;https://github.com/boostorg/filesystem/issues/245
> +                      "0001-filesystem-win-fix-dir-it-net-share.patch" version
> +                      "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
> +                     (boost-patch
> +                      ;; In Boost.Filesystem on Windows, weakly_canonical fails
> +                      ;; to process paths that start with the "\\?\" prefix:
> +                      ;;https://github.com/boostorg/filesystem/issues/247
> +                      "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
> +                      "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")

Going by https://www.boost.org/patches/, you seem to have missed 
0004-filesystem-posix-fix-no-at-apis-missing-include.patch. Perhaps it 
is not required for compilation on supported targets in Guix, but 
neither is Windows a supported target yet you are including 
Windows-specific patches.

Greetings,
Maxime
Greg Hogan Aug. 30, 2022, 8:15 p.m. UTC | #2
On Tue, Aug 30, 2022 at 3:50 PM Maxime Devos <maximedevos@telenet.be> wrote:
> [...]
> Going by https://www.boost.org/patches/, you seem to have missed
> 0004-filesystem-posix-fix-no-at-apis-missing-include.patch. Perhaps it
> is not required for compilation on supported targets in Guix, but
> neither is Windows a supported target yet you are including
> Windows-specific patches.
>
> Greetings,
> Maxime

Thank you, this fourth patch was missed as it is absent from the
release page at
https://www.boost.org/users/history/version_1_80_0.html. I will submit
a revised patch and also check the full patch listing in the future.

Greg
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 818669b757..55296889b8 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -68,7 +68,7 @@  (define (boost-patch name version hash)
 (define-public boost
   (package
     (name "boost")
-    (version "1.79.0")
+    (version "1.80.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
@@ -76,13 +76,27 @@  (define-public boost
                                   (version-with-underscores version) ".tar.bz2"))
               (patches
                (list (boost-patch
-                      ;; 1.79.0 was released with a segmentation fault:
-                      ;; <https://github.com/boostorg/json/issues/692>.
-                      "0001-json-array-erase-relocate.patch" version
-                      "1b0izwj8w92imr8ydzrh522syncprpf82n3kcy6apxn6p54b7p0f")))
+                      ;; Boost.Filesystem directory iterators may fail to
+                      ;; construct for a network share on Windows prior to 10:
+                      ;; https://github.com/boostorg/filesystem/pull/246,
+                      ;; https://github.com/boostorg/filesystem/issues/245
+                      "0001-filesystem-win-fix-dir-it-net-share.patch" version
+                      "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
+                     (boost-patch
+                      ;; In Boost.Filesystem on Windows, weakly_canonical fails
+                      ;; to process paths that start with the "\\?\" prefix:
+                      ;; https://github.com/boostorg/filesystem/issues/247
+                      "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
+                      "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
+                     (boost-patch
+                      ;; Boost.Unordered containers are not in a valid state
+                      ;; after moving:
+                      ;; https://github.com/boostorg/unordered/issues/139
+                      "0003-unordered-valid-after-move.patch" version
+                      "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")))
               (sha256
                (base32
-                "0fggarccddj6q4ifj3kn7g565rbhn4ia1vd45fxb7y57a6fmhpa7"))))
+                "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
     (build-system gnu-build-system)
     (inputs
      (append