diff mbox series

[bug#57026,v3] gnu: Add emacs-denote.

Message ID 20220811223333.9050-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57026,v3] gnu: Add emacs-denote. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 11, 2022, 10:33 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-denote): New variable.

0.5.1 is here! yayyyyyyyy

---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Aug. 26, 2022, 8:37 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-denote): New variable.

Applied. Thank you.

> +    (description
> +"Denote aims to be a simple-to-use, focused-in-scope, and effective
> +note-taking tool for Emacs.")

I replaced this with the description from the homepage. It seemed more
useful.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 690858ba6a..53641a7afa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13618,6 +13618,28 @@  (define-public emacs-log4e
 you to deal with multiple log levels.")
     (license license:gpl3+)))
 
+(define-public emacs-denote
+  (package
+    (name "emacs-denote")
+    (version "0.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~protesilaos/denote")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00f50dhw0x1hn87rc6vkrdwpybnbphg5z0g2c6c4r4cbgaiia8bi"))))
+    (build-system emacs-build-system)
+    (native-inputs (list texinfo))
+    (home-page "https://protesilaos.com/emacs/denote/")
+    (synopsis "Simple notes for Emacs")
+    (description
+"Denote aims to be a simple-to-use, focused-in-scope, and effective
+note-taking tool for Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-logos
   (package
     (name "emacs-logos")