@@ -129,10 +129,9 @@ (define-module (gnu packages racket)
;; This file defines the packages 'racket-vm-cgc', 'racket-vm-bc', and
;; 'racket-vm-cs'. All three are in-place builds of 'racket/src/' and
;; 'racket/collects/' and are installed to 'opt/racket-vm/' in the store
-;; output. The function 'racket-vm-for-system' returns the recomended Racket
-;; VM package for a given system.
+;; output.
;;
-;; We then define the packages 'racket-minimal' and
+;; Using 'racket-vm-cs', we then define the packages 'racket-minimal' and
;; 'racket'. These use Racket's support for ``layered installations'', which
;; allow an immutable base layer to be extended with additional packages.
;; They use the layer configuration directly provide ready-to-install FHS-like
@@ -193,17 +192,6 @@ (define-module (gnu packages racket)
;;
;; CODE:
-(define* (racket-vm-for-system #:optional
- (system (or (%current-target-system)
- (%current-system))))
- "Return 'racket-vm-cs' if we are able to build it for SYSTEM; 'racket-vm-bc'
-otherwise."
- ;; Once we figure out the issues in https://racket.discourse.group/t/950,
- ;; we can use 'racket-vm-cs' everywhere.
- (if (racket-cs-native-supported-system? system)
- racket-vm-cs
- racket-vm-bc))
-
(define %racket-version "8.6") ; Remember to update chez-scheme-for-racket!
(define %zuo-version "1.0") ; defined in racket/src/zuo/zuo.c
(define %racket-commit
@@ -586,7 +574,7 @@ (define-public racket-minimal
(inputs
(list openssl
sqlite
- (racket-vm-for-system)
+ racket-vm-cs
(racket-packages-origin
"base" %racket-origin
'(("base" "pkgs/base")
@@ -704,7 +692,7 @@ (define-public racket
unixodbc
libedit ;; TODO reconsider in light of expeditor and readline-gpl
racket-minimal ;; <-- TODO non-tethered layer
- (racket-vm-for-system)
+ racket-vm-cs
(simple-racket-origin
"2d" (base32 "0fb5v6058ls08xw3zbmqyr2ym0psm119gl9ffgmhm9w8rs9i4dq7")
'("2d" "2d-doc" "2d-lib"))