diff mbox series

[bug#57050,v2,06/13] gnu: chez-scheme: Bootfiles should not be native inputs.

Message ID 760b29c0cb071c142a637e538233a661ad4a5c87.1660215295.git.philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: Update Racket to 8.6. Add Zuo. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Aug. 11, 2022, 11:08 a.m. UTC
This makes a difference for cross-compilation.

* gnu/packages/chez.scm (chez-scheme)[native-inputs]: Move
'chez-scheme-bootstrap-bootfiles' to ...
[inputs]: ... this field.
[arguments]<#:phases>: Update 'unpack-bootfiles' accordingly.
(chez-scheme-for-racket)[native-inputs]: Move
'chez-scheme-for-racket-bootstrap-bootfiles' to ...
[inputs]: ... this field.
---
 gnu/packages/chez.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

Liliana Marie Prikler Aug. 11, 2022, 11:47 a.m. UTC | #1
Am Donnerstag, dem 11.08.2022 um 07:08 -0400 schrieb Philip McGrath:
> This makes a difference for cross-compilation.
The title should be something like "Make bootfiles regular inputs".  If
you want to claim that this makes a difference, please offer an
explanation.  You do not need to restrict yourself to a line here.

> * gnu/packages/chez.scm (chez-scheme)[native-inputs]: Move
> 'chez-scheme-bootstrap-bootfiles' to ...
> [inputs]: ... this field.
> [arguments]<#:phases>: Update 'unpack-bootfiles' accordingly.
> (chez-scheme-for-racket)[native-inputs]: Move
> 'chez-scheme-for-racket-bootstrap-bootfiles' to ...
> [inputs]: ... this field.
Other than that LGTM.

Cheers
Philip McGrath Aug. 11, 2022, 10:45 p.m. UTC | #2
Hi,

On Thu, Aug 11, 2022, at 7:47 AM, Liliana Marie Prikler wrote:
> Am Donnerstag, dem 11.08.2022 um 07:08 -0400 schrieb Philip McGrath:
>> This makes a difference for cross-compilation.
> The title should be something like "Make bootfiles regular inputs".

To me, it would not be clear what makes an input "regular". Or perhaps the unclear part is what makes an input *not* "regular".

>  If
> you want to claim that this makes a difference, please offer an
> explanation.  You do not need to restrict yourself to a line here.
>

I'm not sure what's unclear here. If you are on x86_64 and trying to cross-compile for riscv64, you need to have generated riscv64 machine code, not x86_64.

-Philip
Liliana Marie Prikler Aug. 12, 2022, 4:21 a.m. UTC | #3
Am Donnerstag, dem 11.08.2022 um 18:45 -0400 schrieb Philip McGrath:
> Hi,
> 
> On Thu, Aug 11, 2022, at 7:47 AM, Liliana Marie Prikler wrote:
> > Am Donnerstag, dem 11.08.2022 um 07:08 -0400 schrieb Philip
> > McGrath:
> > > This makes a difference for cross-compilation.
> > The title should be something like "Make bootfiles regular inputs".
> 
> To me, it would not be clear what makes an input "regular". Or
> perhaps the unclear part is what makes an input *not* "regular".
"Regular" means "not native and not propagated", i.e. just "inputs".

> > If you want to claim that this makes a difference, please offer an
> > explanation.  You do not need to restrict yourself to a line here.
> > 
> 
> I'm not sure what's unclear here. If you are on x86_64 and trying to
> cross-compile for riscv64, you need to have generated riscv64 machine
> code, not x86_64.
This sentence itself is already ambiguous: ((need to) (have generated)
code) vs. ((need to) have (generated code)).

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index dde2c22ca5..294edca1a4 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -294,6 +294,7 @@  (define-public chez-scheme
     (build-system gnu-build-system)
     (inputs
      (list
+      chez-scheme-bootstrap-bootfiles
       `(,util-linux "lib") ;<-- libuuid
       zlib
       lz4
@@ -302,8 +303,7 @@  (define-public chez-scheme
       ;; for X11 clipboard support in expeditor:
       ;; https://github.com/cisco/ChezScheme/issues/9#issuecomment-222057232
       libx11))
-    (native-inputs (list chez-scheme-bootstrap-bootfiles
-                         chez-nanopass-bootstrap
+    (native-inputs (list chez-nanopass-bootstrap
                          stex-bootstrap))
     (native-search-paths
      (list (search-path-specification
@@ -342,7 +342,7 @@  (define-public chez-scheme
               (when (directory-exists? "boot")
                 (delete-file-recursively "boot"))
               (copy-recursively
-               (search-input-directory (or native-inputs inputs)
+               (search-input-directory inputs
                                        "lib/chez-scheme-bootfiles")
                "boot")))
           ;; NOTE: The custom Chez 'configure' script doesn't allow
@@ -453,12 +453,12 @@  (define-public chez-scheme-for-racket
     (source #f) ; avoid problematic cycle with racket.scm
     (inputs
      (modify-inputs (package-inputs chez-scheme)
-       (delete "libx11" "util-linux:lib")))
+       (delete "libx11" "util-linux:lib")
+        (replace "chez-scheme-bootstrap-bootfiles"
+          chez-scheme-for-racket-bootstrap-bootfiles)))
     (native-inputs
      (modify-inputs (package-native-inputs chez-scheme)
-       (append zuo)
-       (replace "chez-scheme-bootstrap-bootfiles"
-         chez-scheme-for-racket-bootstrap-bootfiles)))
+       (append zuo)))
     (arguments
      (substitute-keyword-arguments (package-arguments chez-scheme)
        ((#:out-of-source? _ #f)