diff mbox series

[bug#56717,2/2] gnu: Add i3-autotiling.

Message ID 767257c5d3ae679d4638341ddca510c17f574cb1.1658580543.git.hako@ultrarare.space
State Accepted
Headers show
Series gnu: Add python-i3ipc and i3-autotiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain July 23, 2022, 12:48 p.m. UTC
* gnu/packages/python-xyz.scm (i3-autotiling): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

\( July 23, 2022, 12:56 p.m. UTC | #1
On Sat Jul 23, 2022 at 1:48 PM BST, Hilton Chain wrote:
> +    (description
> +     "This script uses the python-i3ipc library to switch the layout
> +splith/splitv depending on the currently focused window dimensions.  It works on
> +both sway and i3 window managers.")
I think you should probably change this one, too. 'splith'/'splitv'
doesn't make much sense as there's no mention of sway or i3 until the
end. Also, sway -> Sway :)

    -- (
Ludovic Courtès Aug. 6, 2022, 9:14 p.m. UTC | #2
Hi,

Hilton Chain <hako@ultrarare.space> skribis:

>   gnu: Add python-i3ipc.
>   gnu: Add i3-autotiling.

Applied, thank you, and thanks to the reviewers!

Ludo’.
\( Aug. 6, 2022, 9:14 p.m. UTC | #3
On Sat Aug 6, 2022 at 10:14 PM BST, Ludovic Courtès wrote:
> Applied, thank you, and thanks to the reviewers!

Thanks Ludo! :D

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d67b535d40..fc00779b40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30227,3 +30227,28 @@  (define-public python-i3ipc
      "This package provides a Python library for controlling the i3 and Sway
  window managers.")
     (license license:bsd-3)))
+
+(define-public i3-autotiling
+  (package
+    (name "i3-autotiling")
+    (version "1.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nwg-piotr/autotiling")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hjlvg7095s322gb43r9g7mqlsy3pj13l827jpnbn5x0918rq9rr"))))
+    (build-system python-build-system)
+    (arguments (list #:tests? #f))      ;no tests
+    (native-inputs (list python-wheel))
+    (propagated-inputs (list python-i3ipc))
+    (home-page "https://github.com/nwg-piotr/autotiling")
+    (synopsis "Automatically tile windows in i3 and Sway")
+    (description
+     "This script uses the python-i3ipc library to switch the layout
+splith/splitv depending on the currently focused window dimensions.  It works on
+both sway and i3 window managers.")
+    (license license:gpl3)))