diff mbox series

[bug#56904,v2,1/2] gnu: Add font-chiron-sung-hk.

Message ID y76a68l6cks.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: Add Chiron Fonts. | expand

Commit Message

Hilton Chain Aug. 3, 2022, 6:55 a.m. UTC
From ca098d0f95be47fa4b7f92ea4f5e442a5255e10b Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Wed, 3 Aug 2022 14:34:38 +0800
Subject: [PATCH v2 1/2] gnu: Add font-chiron-sung-hk.

* gnu/packages/fonts (font-chiron-sung-hk): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/fonts.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Liliana Marie Prikler Aug. 3, 2022, 8:17 a.m. UTC | #1
Am Mittwoch, dem 03.08.2022 um 14:55 +0800 schrieb Hilton Chain:
> From ca098d0f95be47fa4b7f92ea4f5e442a5255e10b Mon Sep 17 00:00:00 2001
> From: Hilton Chain <hako@ultrarare.space>
> Date: Wed, 3 Aug 2022 14:34:38 +0800
> Subject: [PATCH v2 1/2] gnu: Add font-chiron-sung-hk.
> 
> * gnu/packages/fonts (font-chiron-sung-hk): New variable.
> 
> Signed-off-by: Hilton Chain <hako@ultrarare.space>
Signed-off-by is for committers :)
> ---
>  gnu/packages/fonts.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
> 
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 9ff2035a10..0d70e4460b 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -2747,3 +2747,24 @@ (define-public font-lxgw-wenkai-tc
>      (synopsis "LXGW WenKai TC / 霞鶩文楷 TC")
>      (description "The Traditional Chinese Version of LXGW WenKai.")
>      (license license:silofl1.1)))
> +
> +(define-public font-chiron-sung-hk
> +  (package
> +    (name "font-chiron-sung-hk")
> +    (version "1.005")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://github.com/chiron-fonts/chiron-sung-hk")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "0iqlnb7825kisg2avhr9hwwvb4jw8f642vvmms5dw6m9czzydpgw"))))
> +    (build-system font-build-system)
> +    (home-page "https://chiron-fonts.github.io/")
> +    (synopsis "昭源宋體")
The synopsis should be in English.  We use gettext for i18n and use
Weblate [1,2] for translations.  Sadly, there's no traditional Chinese
translation yet, but you could add it :)
> +    (description
> +     "Chiron Sung HK (昭源宋體) is a Traditional Chinese serif
> + typeface based on Adobe’s Source Han Serif (a.k.a. Google’s Noto
> Sans CJK).")
As above.
> +    (license license:silofl1.1)))

Cheers

[1] https://translate.fedoraproject.org/projects/guix
[2] https://translate.fedoraproject.org/projects/guix/packages/
宋文武 Aug. 3, 2022, 9:05 a.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

>> [...]
>> +    (synopsis "昭源宋體")
> The synopsis should be in English.  We use gettext for i18n and use
> Weblate [1,2] for translations.  Sadly, there's no traditional Chinese
> translation yet, but you could add it :)

Hello, I had pushed those patches.  Feel free to update the synopsis and
description in another patch...  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ff2035a10..0d70e4460b 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2747,3 +2747,24 @@  (define-public font-lxgw-wenkai-tc
     (synopsis "LXGW WenKai TC / 霞鶩文楷 TC")
     (description "The Traditional Chinese Version of LXGW WenKai.")
     (license license:silofl1.1)))
+
+(define-public font-chiron-sung-hk
+  (package
+    (name "font-chiron-sung-hk")
+    (version "1.005")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/chiron-fonts/chiron-sung-hk")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0iqlnb7825kisg2avhr9hwwvb4jw8f642vvmms5dw6m9czzydpgw"))))
+    (build-system font-build-system)
+    (home-page "https://chiron-fonts.github.io/")
+    (synopsis "昭源宋體")
+    (description
+     "Chiron Sung HK (昭源宋體) is a Traditional Chinese serif
+ typeface based on Adobe’s Source Han Serif (a.k.a. Google’s Noto Sans CJK).")
+    (license license:silofl1.1)))