diff mbox series

[bug#56252] Fw: Re: [PATCH] gnu: polkit-mozjs: Fix native-inputs usage.

Message ID Q0Y3IK7kQZOJM4gJF9WX07NzpvpPbjjwEOClNLNNfXjyXyCC9nf64e_FIP6S8DQAbvxZC1o6Dl7k1IV5UJlDcUu_aR71yhU2WW9IXg5OQ1w=@jeandudey.tech
State Accepted
Headers show
Series [bug#56252] Fw: Re: [PATCH] gnu: polkit-mozjs: Fix native-inputs usage. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jean Pierre De Jesus DIAZ June 27, 2022, 9:32 p.m. UTC
Fixed it and changed commit message.

Thanks!

—
Jean-Pierre De Jesus DIAZ

------- Original Message -------
On Monday, June 27th, 2022 at 2:19 PM, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:


> Am Montag, dem 27.06.2022 um 10:34 +0000 schrieb Jean Pierre De Jesus
> DIAZ:
>
> > - (lambda* (#:key inputs #:allow-other-keys)
> > - (let ((xsldoc (string-append (assoc-ref inputs
> > "docbook-xsl")
> > + (lambda* (#:key native-inputs #:allow-other-keys)
> > + (let ((xsldoc (string-append (assoc-ref native-inputs
> > "docbook-xsl")
>
> The correct usage would be (or native-inputs inputs).
>
> Cheers

Comments

Marius Bakke July 20, 2022, 1:12 p.m. UTC | #1
> From 7a6b55bb34a61ab393b5a994dc1467f5f25a2992 Mon Sep 17 00:00:00 2001
> Message-Id: <7a6b55bb34a61ab393b5a994dc1467f5f25a2992.1656347660.git.me@jeandudey.tech>
> From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
> Date: Mon, 27 Jun 2022 12:18:05 +0200
> Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.
>
> * gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
>   `inputs' to `(or native-inputs inputs)' when searching for `docbook-xsl'
>   path.

Pushed to 'staging' in 7767d30f55, thanks!
diff mbox series

Patch

From 7a6b55bb34a61ab393b5a994dc1467f5f25a2992 Mon Sep 17 00:00:00 2001
Message-Id: <7a6b55bb34a61ab393b5a994dc1467f5f25a2992.1656347660.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.

* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
  `inputs' to `(or native-inputs inputs)' when searching for `docbook-xsl'
  path.
---
 gnu/packages/polkit.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..9a3703b196 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -119,10 +120,11 @@  (define-public polkit-mozjs
                 (("@INTROSPECTION_TYPELIBDIR@")
                  (string-append out "/lib/girepository-1.0/"))))))
          (add-after 'unpack 'fix-manpage-generation
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
-                                          "/xml/xsl/docbook-xsl-"
-                                          ,(package-version docbook-xsl))))
+           (lambda* (#:key inputs native-inputs #:allow-other-keys)
+             (let ((xsldoc (string-append
+                             (assoc-ref (or native-inputs inputs) "docbook-xsl")
+                             "/xml/xsl/docbook-xsl-"
+                             ,(package-version docbook-xsl))))
                (substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
                  (("http://docbook.sourceforge.net/release/xsl/current")
                   xsldoc)))))
-- 
2.36.1