diff mbox series

[bug#56331] gnu: Graft tzdata to install leap-seconds.list.

Message ID 20220701015314.7197-1-antero@mailbox.org
State New
Headers show
Series [bug#56331] gnu: Graft tzdata to install leap-seconds.list. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr July 1, 2022, 1:53 a.m. UTC
* gnu/packages/base.scm (tzdata)[replacement]: New field.
(tzdata-leap-seconds-list): New private variable.
---
 gnu/packages/base.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Antero Mejr July 1, 2022, 2:08 a.m. UTC | #1
leap-seconds.list is required by the hare programming language (which is
currently being packaged) for accurate datetime calculations.

It is optionally used by ntpd with the "leapfile" directive in ntpd.conf.
\( July 1, 2022, 9:43 a.m. UTC | #2
On Fri Jul 1, 2022 at 2:53 AM BST, Antero Mejr via Guix-patches via wrote:
> @@ -1305,6 +1305,7 @@ (define-public tzdata
>      ;; This package should be kept in sync with python-pytz in (gnu packages
>      ;; time).
>      (version "2022a")
> +    (replacement tzdata-leap-seconds-list)
>      (source (origin
>               (method url-fetch)
>               (uri (string-append
> @@ -1390,6 +1391,19 @@ (define-public tzdata
>  and daylight-saving rules.")
>      (license public-domain)))

There's no need to graft it, as long as you make sure tzdata-for-tests
isn't rebuilt.
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4bdc3e7792..b265b429d5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1305,6 +1305,7 @@  (define-public tzdata
     ;; This package should be kept in sync with python-pytz in (gnu packages
     ;; time).
     (version "2022a")
+    (replacement tzdata-leap-seconds-list)
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -1390,6 +1391,19 @@  (define-public tzdata
 and daylight-saving rules.")
     (license public-domain)))
 
+(define tzdata-leap-seconds-list
+  (package
+    (inherit tzdata)
+    (arguments
+     (substitute-keyword-arguments (package-arguments tzdata)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-after 'install 'copy-leap-seconds-list
+              (lambda _
+                (copy-file "leap-seconds.list"
+                           (string-append
+                            #$output "/share/zoneinfo/leap-seconds.list"))))))))))
+
 ;;; A "fixed" version of tzdata, which is used in the test suites of glib and R
 ;;; and a few other places. We can update this whenever we are able to rebuild
 ;;; thousands of packages (for example, in a core-updates rebuild). This package