diff mbox series

[bug#56151] : gnu: ppp: Fix cross-compilation

Message ID uoHyGcjHXQz3A3tZiXk1zJx5QfIvpzVMCByEQHwIF2I_pJ7bizBAbKlA5WwrwuByotihc8RWfunxIOVAssLwF0TTdXCdemo57I9SAcwxurg=@jeandudey.tech
State Accepted
Headers show
Series [bug#56151] : gnu: ppp: Fix cross-compilation | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jean Pierre De Jesus DIAZ June 22, 2022, 6:40 p.m. UTC
Building `ppp` right now fails when cross-compiling for other
systems. Discovered it while generating an installation image for
RockPro64 on a `x86-64-linux-gnu` system.

guix build ppp --keep-failed \
               --target=aarch64-linux-gnu

This patch removes an outdated substitution, and modifies the existing ones to match what the source code expects.

Comments

Guillaume Le Vaillant June 25, 2022, 4:45 p.m. UTC | #1
Patch pushed as aae46e30d953dd24a5e04ffa5a397c70ef42b945.
Thanks.
diff mbox series

Patch

From 99ed433400d7d33b4b9811ac22fdfb4b637492fd Mon Sep 17 00:00:00 2001
Message-Id: <99ed433400d7d33b4b9811ac22fdfb4b637492fd.1655922891.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Wed, 22 Jun 2022 20:29:05 +0200
Subject: [PATCH] gnu: ppp: Fix cross-compilation.

* gnu/packages/samba.scm (ppp)[arguments]: Use G-Expressions. Remove
unused substitution. Fix OpenSSL and libpcap include paths.
---
 gnu/packages/samba.scm | 34 +++++++++++++++++-----------------
 1 file changed, 17 insertions(+), 17 deletions(-)

diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..208dca94ca 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -469,23 +470,22 @@  (define-public ppp
                 "1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                    ; no check target
-       #:make-flags '("CC=gcc")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'patch-Makefile
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((libc    (assoc-ref inputs "libc"))
-                   (openssl (assoc-ref inputs "openssl"))
-                   (libpcap (assoc-ref inputs "libpcap")))
-               (substitute* "pppd/Makefile.linux"
-                 (("/usr/include/crypt\\.h")
-                  (string-append libc "/include/crypt.h"))
-                 (("/usr/include/openssl")
-                  (string-append openssl "/include/openssl"))
-                 (("/usr/include/pcap-bpf.h")
-                  (string-append libpcap "/include/pcap-bpf.h")))
-               #t))))))
+      (list #:tests? #f                    ;; No "check" target
+            #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+            #:phases
+            #~(modify-phases %standard-phases
+                (add-before 'configure 'patch-Makefile
+                  (lambda* (#:key inputs #:allow-other-keys)
+                    (let ((openssl (assoc-ref inputs "openssl"))
+                          (libpcap (assoc-ref inputs "libpcap")))
+                      (substitute* "pppd/Makefile.linux"
+                        (("/usr/include/openssl")
+                         (string-append openssl "/include"))
+                        (("-DPPP_FILTER")
+                         (string-append "-DPPP_FILTER -I" libpcap "/include")))
+                      (substitute* "pppd/pppcrypt.h"
+                        (("des\\.h") "openssl/des.h")))
+                    #t)))))
     (inputs
      (list libpcap
            (@ (gnu packages tls) openssl)))
-- 
2.36.1