diff mbox series

[bug#53603] doc: Add files and symlink-manager home services.

Message ID 87zgngm5wm.fsf@trop.in
State Accepted
Headers show
Series [bug#53603] doc: Add files and symlink-manager home services. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Jan. 28, 2022, 11:52 a.m. UTC
* doc/guix.texi (Essential Home Services): Add files and symlink-manager home
services.
---
 doc/guix.texi | 65 +++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 65 insertions(+)

Comments

Ludovic Courtès June 22, 2022, 10:43 a.m. UTC | #1
Hi Andrew,

Andrew Tropin <andrew@trop.in> skribis:

> * doc/guix.texi (Essential Home Services): Add files and symlink-manager home
> services.
> ---
>  doc/guix.texi | 65 +++++++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 65 insertions(+)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index c94f85589f..2edea2c943 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -37500,12 +37500,77 @@ users @emph{should not} use this service, in most cases it's better to extend
>  the required command using the appropriate service type.
>  @end defvr
>  
> +@defvr {Scheme Variable} home-files-service-type
> +The service of this type allows to specify a list of files, which will
> +go to @file{~/.guix-home/files}, usually it contains configuration files
> +(to be more precise it contains symlinks to files in @file{/gnu/store}),
> +which should be placed in @file{$XDG_CONFIG_DIR} or in rare cases in
> +@file{$HOME}.  It accepts extension values in the following format:
> +
> +@lisp
> +`(("config/sway/config" ,sway-file-like-object)
> +  ("config/tmux/tmux.conf" ,(local-file "./tmux.conf")))
> +@end lisp

I think you wrote it shortly before ‘home-files-service-type’ was
changed to not prepend a dot to file names.

Would you like to update it and resubmit?  That’d be a welcome addition.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index c94f85589f..2edea2c943 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -37500,12 +37500,77 @@  users @emph{should not} use this service, in most cases it's better to extend
 the required command using the appropriate service type.
 @end defvr
 
+@defvr {Scheme Variable} home-files-service-type
+The service of this type allows to specify a list of files, which will
+go to @file{~/.guix-home/files}, usually it contains configuration files
+(to be more precise it contains symlinks to files in @file{/gnu/store}),
+which should be placed in @file{$XDG_CONFIG_DIR} or in rare cases in
+@file{$HOME}.  It accepts extension values in the following format:
+
+@lisp
+`(("config/sway/config" ,sway-file-like-object)
+  ("config/tmux/tmux.conf" ,(local-file "./tmux.conf")))
+@end lisp
+
+Each nested list contains two values: a subdirectory and file-like
+object.  After building a home environment @file{~/.guix-home/files}
+will be populated with apropiate content and all nested directories will
+be created accordingly, however, those files won't go any further until
+some other service will do it.  By default a
+@code{home-symlink-manager-service-type}, which creates necessary
+symlinks to files from @file{~/.guix-home/files} in home folder, backs
+up already existing, but clashing configs and other things, is a part of
+essential home services (enabled by default), but it's possible to use
+alternative services to implement more advanced use cases like read-only
+home.  Feel free to experiment and share your results.
+@end defvr
+
 @defvr {Scheme Variable} home-activation-service-type
 The service of this type generates a guile script, which runs on every
 @command{guix home reconfigure} invocation or any other action, which
 leads to the activation of the home environment.
 @end defvr
 
+@defvr {Scheme Variable} home-symlink-manager-service-type
+The service of this type generates a guile script, which will be
+executed during activation of home environment, and do a few following
+steps:
+
+@enumerate
+@item
+Reads the content of @file{files/} directory of current and pending home
+environments.
+
+@item
+Cleans up all symlinks created by symlink-manager on previous
+activation.  Also, sub-directories, which will become empty also will be
+cleaned up.
+
+@item
+Creates new symlinks the following way: It looks @file{files/} directory
+(usually generated with @code{home-files-service-type}), takes the files
+from @file{files/config/} subdirectory and put respective links in
+@env{XDG_CONFIG_DIR}.  For example symlink for
+@file{files/config/sway/config} will end up in
+@file{$XDG_CONFIG_DIR/sway/config}.  The rest files in @file{files/}
+outside of @file{files/config/} subdirectory will be treated slightly
+different: symlink will go to @file{$HOME} and the dot will be appended.
+@file{files/some-program/config} will end up in
+@file{$HOME/.some-program/config}.
+
+@item
+If some sub-directories are missing, they will be created.
+
+@item
+If there is a clashing files on the way, they will be backed up.
+
+@end enumerate
+
+symlink-manager is a part of essential home services and is enabled and
+used by default.
+@end defvr
+
+
 @node Shells Home Services
 @subsection Shells