diff mbox series

[bug#56041] gnu: Add vkmark.

Message ID b9edc90fb6081f2ea0495b9c22527134@schwi.pl
State New
Headers show
Series [bug#56041] gnu: Add vkmark. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tomasz Jeneralczyk June 17, 2022, 3:24 p.m. UTC
* gnu/packages/benchmark.scm (vkmark): Add variable.
---
  gnu/packages/benchmark.scm | 43 ++++++++++++++++++++++++++++++++++++++
  1 file changed, 43 insertions(+)

  ;;;
@@ -36,15 +37,20 @@ (define-module (gnu packages benchmark)
    #:use-module (guix build-system cmake)
    #:use-module (guix build-system gnu)
    #:use-module (guix build-system python)
+  #:use-module (guix build-system meson)
    #:use-module (gnu packages)
    #:use-module (gnu packages autotools)
    #:use-module (gnu packages base)
    #:use-module (gnu packages c)
    #:use-module (gnu packages check)
+  #:use-module (gnu packages cmake)
    #:use-module (gnu packages compression)
    #:use-module (gnu packages kde-frameworks)
    #:use-module (gnu packages databases)
    #:use-module (gnu packages docbook)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages graphics)
    #:use-module (gnu packages linux)
    #:use-module (gnu packages lua)
    #:use-module (gnu packages maths)
@@ -57,6 +63,8 @@ (define-module (gnu packages benchmark)
    #:use-module (gnu packages python-web)
    #:use-module (gnu packages python-xyz)
    #:use-module (gnu packages qt)
+  #:use-module (gnu packages vulkan)
+  #:use-module (gnu packages xorg)
    #:use-module (gnu packages xml)
    #:use-module (ice-9 match))

@@ -584,3 +592,38 @@ (define-public sysbench
  @item
  @end itemize")
      (license license:gpl2+)))
+
+(define-public vkmark
+  (let ((commit "d872846e2e7c47010c11227eb713d00ccfdd35c6")
+        (revision "1"))
+    (package
+      (name "vkmark")
+      (version (git-version "2017.08" revision commit))
+      (source (origin
+                (method git-fetch)
+                (file-name (git-file-name name version))
+                (uri (git-reference
+                      (url "https://github.com/vkmark/vkmark")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  
"0zlryz8i8jvl160bv30ig5nd9h4ahpjfw53ys839i41xi80jjg5d"))))
+      (build-system meson-build-system)
+      (native-inputs (list pkg-config cmake))
+      ;; The kms back-end, as it is, seems to have bitrot
+      ;; and would need maintenance to work with current Mesa:
+      ;; https://gitlab.freedesktop.org/mesa/mesa/-/commit/5e6db1916806
+      (inputs (list vulkan-loader
+                    vulkan-headers
+                    glm
+                    assimp
+                    libxcb
+                    xcb-util-wm
+                    wayland-protocols
+                    wayland))
+      (synopsis "Benchmark for Vulkan")
+      (description
+       "vkmark is an extensible Vulkan benchmarking suite with 
targeted, configurable
+scenes.")
+      (home-page "https://github.com/vkmark/vkmark")
+      (license license:lgpl2.1))))

base-commit: d6bd483cd53cedc8da39fcc6c419f7241080ed21

Comments

\( June 17, 2022, 7:10 p.m. UTC | #1
Hi! :D This package seems good to me: passes all lints, builds, and
style looks okay.

On Fri Jun 17, 2022 at 4:24 PM BST, Tomasz Jeneralczyk wrote:
> +(define-public vkmark
> +  (let ((commit "d872846e2e7c47010c11227eb713d00ccfdd35c6")
> +        (revision "1"))

I think it's common to include an explanation of why tags aren't used :)

> +                (file-name (git-file-name name version))
> +                (uri (git-reference
> +                      (url "https://github.com/vkmark/vkmark")
> +                      (commit commit)))

Nitpick: file-name usually comes after uri in most of the packages I've
seen. Maybe run guix style, if you haven't already.

> +      (native-inputs (list pkg-config cmake))

Why include cmake? It seems to compile without it :)

> +      (synopsis "Benchmark for Vulkan")

Maybe expand this to "Extensible benchmarking suite for Vulkan" or
something? I'd say this synopsis is a bit too short.
\( June 17, 2022, 7:59 p.m. UTC | #2
On Fri Jun 17, 2022 at 8:10 PM BST, ( via Guix-patches via wrote:
> Maybe run guix style, if you haven't already.

And only then I discover how questionable guix style's formatting
choices are... I retract this suggestion :P
\( June 18, 2022, 8:13 a.m. UTC | #3
Forwarded message from Tomasz Jeneralczyk on Fri Jun 17, 2022 at 10:40 PM:
On 2022-06-17 19:10, ( wrote:

> On Fri Jun 17, 2022 at 4:24 PM BST, Tomasz Jeneralczyk wrote:

> I think it's common to include an explanation of why tags aren't used 

> :)



The only tag in the repo is "2017.08" and it's a bit old considering

the latest commit was just a few days ago. I did not manage to compile

the old version successfully anyway, I suspect the api of the libraries

it uses has changed significantly in the meantime.



On the latest commit all benchmark suites run just fine for me on xcb 

backend,

and someone on irc confirmed it works on wayland too so I rolled with 

that.



Do you want me to write a comment there explaining why I used a specific 

commit?



> Nitpick: file-name usually comes after uri in most of the packages I've

> seen. Maybe run guix style, if you haven't already.



All I can tell is guix style does not do much, could not even fix this 

simple

issue.



> Why include cmake? It seems to compile without it :)



You are right. I think it is there because during building process it 

spits

out "Found CMAKE: NO" during compilation and I thought that was an 

issue.



> Maybe expand this to "Extensible benchmarking suite for Vulkan" or

> something? I'd say this synopsis is a bit too short.



your suggestion sounds good.



So do I send a new patch in this thread (with the same or a different 

subject?) or make a new thread with it?


Please only send plain-text email; see <https://useplaintext.email>. Thanks!
\( June 18, 2022, 8:13 a.m. UTC | #4
Forwarded message from ( on Fri Jun 17, 2022 at 11:47 PM:
On Fri Jun 17, 2022 at 11:40 PM BST, Tomasz Jeneralczyk wrote:

> Do you want me to write a comment there explaining why I used a specific 

> commit?



Yeah, that'd be good and seems to be usual practise :)



> > Nitpick: file-name usually comes after uri in most of the packages I've

> > seen. Maybe run guix style, if you haven't already.

>

> All I can tell is guix style does not do much, could not even fix this 

> simple

> issue.



Yeah, i just replied to my message saying that I no longer recommend

guix style, since it completely wrecked the formatting of a package I

was working on... Interesting that it doesn't do anything here, though.



> So do I send a new patch in this thread (with the same or a different 

> subject?) or make a new thread with it?



(1) make modifications

(2) commit modifications

(3) rebase <https://git-rebase.io> the commits as fixups for the original

    commits so that your new patchset will be completely independent of

    the original

(4) git send-email -v2 to _this_ thread <56041 <at> debbugs.gnu.org>, not a

    new one



This will send an amended set of commits. Note that these commits should

not be fixes for the earlier commits, but modified versions of the original

commits (so that the v2 patches can be applied without first applying

the v1 patches).


Please only send plain-text email; see <https://useplaintext.email>. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index b167c6de6e..98d9390472 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -11,6 +11,7 @@ 
  ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer 
<maxim.cournoyer@gmail.com>
  ;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
  ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
  ;;;
  ;;; This file is part of GNU Guix.