diff mbox series

[bug#55971] gnu: htop: Update to 3.2.1.

Message ID 94cceba2b9bf4e70bbc0f284709d69e053381ac2.1655215897.git.code@greghogan.com
State Accepted
Headers show
Series [bug#55971] gnu: htop: Update to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan June 14, 2022, 2:15 p.m. UTC
* gnu/packages/admin.scm (htop): Update to 3.2.1.
---
The htop package has no dependencies.

 gnu/packages/admin.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Tom Fitzhenry June 14, 2022, 2:46 p.m. UTC | #1
LGTM. This built and executed on aarch64.

$ file /gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop
/gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop: ELF 64-bit LSB executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /gnu/store/gfjp8gfv4xxschbaxvldpigadfwqazhw-glibc-2.33/lib/ld-linux-aarch64.so.1, for GNU/Linux 2.6.32, stripped
$ /gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop --version
htop 3.2.
Greg Hogan June 14, 2022, 3:22 p.m. UTC | #2
On Tue, Jun 14, 2022 at 10:46 AM Tom Fitzhenry <tom@tom-fitzhenry.me.uk> wrote:
>
> LGTM. This built and executed on aarch64.
>
> $ file /gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop
> /gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop: ELF 64-bit LSB executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /gnu/store/gfjp8gfv4xxschbaxvldpigadfwqazhw-glibc-2.33/lib/ld-linux-aarch64.so.1, for GNU/Linux 2.6.32, stripped
> $ /gnu/store/20nz2xg1ln9a6ly54ccyw6g8gx8z42bi-htop-3.2.1/bin/htop --version
> htop 3.2.

Thanks, Tom!

And I just realized that here and in #55974 I said 'dependencies' when
I intended 'dependents'. Hopefully this was understood in the context
of the patch workflow.

Greg
Tobias Geerinckx-Rice June 14, 2022, 8:52 p.m. UTC | #3
Greg Hogan 写道:
> * gnu/packages/admin.scm (htop): Update to 3.2.1.

Pushed as 142d136abd21b22ac1f54de7f782042b95ddfd7d.

Thanks!

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 48000b9b6e..21983848a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -680,7 +680,7 @@  (define-public ttyload
 (define-public htop
   (package
     (name "htop")
-    (version "3.2.0")
+    (version "3.2.1")
     (source
      (origin
        (method git-fetch)
@@ -688,7 +688,7 @@  (define-public htop
              (url "https://github.com/htop-dev/htop")
              (commit version)))
        (sha256
-        (base32 "16l1r2ixzs640ybqp2x8bfyvk98kiywy7k3sjmp5j5npdzn5ryd7"))
+        (base32 "0yfmkw3y4qyd42svhpiijif7krvmnb8z88y6h9g4fwf7sfynq2rk"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (inputs